CentOS 6.0 Perl problems

Hello again,
Not sure how to name this one: bug or not-yet-implemented-feature :slight_smile: Tried yesterday the new os wonder CentOS 6 - very cool stuff, but when getting to Cloud/Virtual/Webmin got problems.
Installed Cloudmin GPL via your script but after login all I was seeing was an Error - Perl execution failed and some other mambo-jambo (Mambo-Joomla! ? lol) network related. Figured it was the new CentOS not being recognised and modified /etc/webmin/config file:

real_os_type=CentOS Linux

But then i tried to install virtualmin with the script and it threw “Failed to detect operating system” Webmin & Coudmin pages are full of Perl errors, almost impossible to test anything.

Also This system cannot be a KVM host : No bridge interfaces like br0 were found - should br0 be created automatically?

Thank you and hope we will see soon some usable versions of ur great suite!

Hmmm shall i uninstall Cloudmin? Or better do a fresh install of CentOS 6 (it’s on a test machine)…


Due to the newness of CentOS 6, we hadn’t gotten a lot of testing in on that yet. There’s is indeed a CentOS 6 detection bug with Cloudmin – you can read about it (and a workaround) here: