Centos 5.5 to 5.6 Yum Update

Installed Virtualmin on Centos 5.5 server via the install.sh file a few months back, been updating all available packages via Virtualmin (Vitualmin at version 3.86 GPL), but so far Centos 5.6 hasn’t become available.

Have tried Yum Clean All, followed by yum Update but no packages available.

I’ve not changed the default repositories.

Should Centos 5.6 be available through Virtualmin by now?

Have two of these servers, setup within days of each other same issue.


Well, it sounds like yum is working properly, since it was able to pull down the latest Virtualmin.

My suspicion is that something may be awry with the CentOS mirror being used.

CentOS usually contains a file something along the lines of “/etc/yum.repos.d/CentOS-Base.repo” which specifies the servers it uses. There may be a lot of lines in it, but of particular interest are the sections labeled “base” and “updates”.

What’s in those two sections, can you paste that in here?


Thanks Eric, relevant contents of the file below:

name=CentOS-5 - Base

#released updates
name=CentOS-5 - Updates

These are Godaddy virtual servers, I recognise the secureserver.net part as part of their system.


I changed the updates part to

name=CentOS-$releasever – Updates

which resulted in quite a few new updates (updated them), but not Centos 5.5 to 5.6.


Mmm, it looks like it may be related to the repo’s being used to pull down your updates. You probably want to make a similar change for the “base” section. Try setting it to this:

[base] name=CentOS-$releasever - Base mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os #baseurl=http://mirror.centos.org/centos/$releasever/os/$basearch/ gpgcheck=1 gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5

That appears to have sorted the problem, seeing Centos 5.6 updates available through virtualmin, not updated yet, waiting until the morning (4:30am in the UK now) just incase it all goes wrong.

Is it just me or do all server problems happen half an hour before you plan to go to sleep :slight_smile: Lost count the number of times I’m finishing up for the night and something has gone wrong that’s kept me up hours!

Thanks for the help Eric

Ran the upgrade this morning and it worked.

Thanks again.

Time to research upgrading PHP 5.1.6 to 5.3, Centos apparently locked their PHP verion to 5.1.6.



Well, if you have any questions regarding upgrading to PHP, feel free to open up a new forum thread on that topic… but two quick mentions are that CentOS 5.6 includes a package named “php53” containing PHP 5.3, which would replace your currently installed PHP 5.1.6.

Alternatively, there’s the Virtualmin Bleed repo, which contains PHP 5.2.17: