Can't update using yum or from in Virtualmin - repomd.xml: [Errno 14] HTTP Error 404

Hi I am trying to update an old Centos 5 server but getting this message:

Building complete list of updates ..

Now updating bind usermin webmin …

Installing package(s) with command /usr/bin/yum -y install bind.x86_64 usermin.noarch webmin.noarch ..

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * webtatic-el5: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: virtualmin. Please verify its path and try again

.. install failed!

Searched around but lost a little. Trying to retrieve that xml file via a browser on a Windows pc & separate network also returns a 404.

Any help is appreciated.

Same issue here - out of nowhere. Did you discover the solution?

CentOS 5 reached end of life over a year ago. You’re running exploitable everything at this point…updating Virtualmin is the least of your worries.

You need to migrate to a maintained CentOS version. I’d recommend CentOS 7, since it’ll be supported for several more years.

Ha! thanks Joe! - it’s not as bad as it sounds - I was actually getting the same error “[Errno 14] HTTP Error 404: Not Found” on Centos 6.9"

I since found posts advising “yum clean all” which solved the issue for me.

Thanks again for your help

Yes, there’s a quirk in yum where it’ll try to load stuff based on cached metadata that no longer exists when the repo has been updated. The createrepo tool began generating hashed filenames for the metadata, which allows versioned metadata, but it introduces a race condition for old versions of yum (I think it is version dependant, but maybe not). I haven’t figured out how to deal with that. Maybe I can force createrepo to use the old style metadata for old CentOS 6 repos.