Can't "Throw Away" mail using a filter

I set up a user’s usermin account to basically forward all email to an external email address. I am doing it this way to make sure messages get scanned for spam before forwarding. Problem now is the mailbox fills up because it is not getting checked. I don’t want the disk space being used up because once it does the stupid system will send bounces due to disk quota being exceeded.

Anyway, the forward works fine but when I click “no” on the question “Also deliver normally?” it still delivers messages “normally” to the mailbox which I don’t want. So I tried adding a new filter processed after the forward that basically always throws away all messages. This does not work however, and mail continues to get delivered to the mailbox.

Ok I just ran some test and it seems only non-SPAM messages(<5 on my system) get treated this way. Anything identified as spam but not marked for deletion by the spam settings for the domain ends up getting forwarded AND dumped in the mailbox. Anything not marked as spam gets forwarded and deleted. So <5 gets forwarded and thrown away which is good, 5-10 don’t get thrown away(bad), >10 get deleted as spam(good).

Any idea how to fix this so mail that is marked as spam but not above the delete threshold still gets forwarded and deleted?



You’re right that spam doesn’t apply to the “Deliver Normally” options – once an email is tagged as spam, it runs through a different set of rules than what normal email would see.

There may be a different way to go about tackling that though.

If you look in Server Configuration -> Spam and Virus Delivery, you’ll see an option named “Automatically delete spam”. That allows you to have spam in a user’s spam folder deleted more frequently. You can delete it based on how old it is, or how large the mailbox is.

Would that resolve your issue?


Ok, that will work, though I would prefer it only apply to one mailbox. That’s ok though, it will do the trick.

Thanks a bunch!