Can't send mail

centos 5.4 and virtualmin. Installed virtualmin with command. New build
My setup is as follows
hostname is host0.domain. I have 2 virtual server. One (host1.domain) shares an IP with host0.domain and the other is a virtual IP by itself.(host2.domain)
host2.domain I have added ssl from godaddy and copied to usermin, dovecot, & postfix.
The domains seem to be working fine. I have not had any connection issues with them.
I am however having problems sending mail through them. I can connect and download using pop3 but can not connect to smtp.
I have no problem sending from usermin or from any of the block of IP addresses I have from my ISP. I have a block of 5 usable addresses,,,, & These I have no problem connecting with.
I have my laptop connected by wireless to my neighbors house and it is from here I can not connect. I have also tried from work and my brothers house.
I have looked at the mail log and I can’t even see where my client has tried to connect on smtp. It shows when pop3 has connected.
I have tested my DNS sites off the internet such as and they all show ok
I have also tried to send through host0.domain & host1.domain, also not showing on mail log
I am a noobie
Any help would be great

I forgot to mention I had searched this forum and many other places and have tried different things but nothing helped.

Yeah, a lot of ISP’s block port 25 to external servers – they require you to send email through their mail relay.

The trick would be to either use their mail relay, or enable SMTPS and/or Submission on your server, and connect to Postfix on that alternate port (465 or 587).

To enable those, you can edit /etc/postfix/, and uncomment the lines near the top that start with “submission” and “smtps”.


My port is not blocked because I have been running a mail server for over a year on a windows machine. I switched to centos because of the prices of windows systems.
I have tried the above and adjusted the mail clients and it still does not work.