Can't save change due to email starting with a number

OS type and version Ubuntu Linux 18.04.6
Webmin version 2.013
Virtualmin version 7.7
Related packages SUGGESTED

A customer uses mail and has a forward to two mailaddresses. He wants to delete one of the forward mailaddresses, but when he saves the changes the following error occurs: ‘Failed to save user: Username cannot begin with a number’

I believe the mail was moved to this server, so the mail was originally made on an older server. Is there any other way to delete the forwarding mailaddress?

does the username start with a number ?

I have a few domains that start with a number eg and have noticed that Virtualmin converts the user name to onedomain despite the domain name is valid. (and the username under RFC5322) this can get confusing for all.

The mailaddress and username both start with the number 4.

Both the mailaddress and username start with the number 4. This is not converted to ‘four…’

How did you create the users through virtualmin ? I doubt that, as virtualmin will not allow you to insert a user that starts with a number, however useradd/adduser would allow a user to be created such as 4tfhelp like so

you can send mail also with something like this

echo “test message” | mailx -s ‘test subject’

as your new user which delivers correctly

maybe @staff will have an idea on how to fix this as it is possible in Ubuntu to create a user & send email that starts with a numeric

The username/mailaddress was created on an older version. Through a back-up we moved the whole domain, so mail and website, to a newer server and therefore newer version of virtualmin. So the mailaddress is created years ago, apparantly it was possible back then.

The customer wants to remove the forwarding mailaddress and add a new one.

an you (or owner of the VS) go to Virtualmin (for the domain)->Edit User->(select the user)Edit User->Mail Forwarding Settings-> Yes, forward to addresses (to remove the unwanted forward

But the change can not be saved because the username starts with a digit. Virtualmin will not save data for a user name that starts with a digit

Exactly, so is there a way to work around this?

I am assuming the primary username does not start with a number.
(I cannot see how that could be done)

So does setting the Yes, forward to addresses to unchecked remove the bad forward (can you even set a new forward? while a bad one exists) I guess this is a bit of a special case and perhaps needs a GUI chage here to optionally transfer the listed forwards to a new list and to delete the unwanted ones. I am not even sure how they were allowed in, in the first place. (It is a nuisance either way as I have had quite a few clients who want their email addresses to conform to RFC5322 and start with a number)

That is exactly the issue

I’ll add a check that if a username is already invalid, we don’t complain when saving if it doesn’t change.

That would be great! However how long will it take before we can actually make the changes? The customers really needs to change the forwarding emailadresses. Is there for now another way we can change the forwarding mailadresses right now, so without the check.

Hi Jamie, is there any updates on this? The customer really wants to make some changes. Is there a way to work around this for now?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.