Can't remove MBOX-format folders from Usermin

I can’t remove the /home/.../mail/... folders. One of them doesn’t even have a checkbox, and the other two don’t go away when I try to delete them.

This is in the Manage Folders section of Usermin. I have access to Webmin as root. How do I remove these folders so that Usermin is Maildir-only?

Hello @LoganDark and welcome to the community.

When a virtual server is created, a user is automatically created along with all associated directories. From what I can see of the obfuscated screenshot that you have posted, those are the directories that you are attempting to delete manually.

Removing user directories is as easy as removing the virtual server user: In Virtualmin -> Edit User, see the list of users, select one and then hit the “Delete selected user” button.

Usermin is Maildir only by default, I think. Could @Ilia confirm? You could view the option for mailbox format via Webmin -> Servers -> Dovecot -> Edit Config Files, select mail.conf from the drop-down and see what mail_location has been set to.

edit: FYI, this is the original reply that got rejected by Akismet, that’s why there’s another one below…


No, that’s not what I’m trying to accomplish. I’m trying to remove the mail folders that use the mbox format.

No, it’s not. It’s mbox-only by default, and the default folders are the ones it’s not letting me remove.

To clarify, I do not mean filesystem directories when I say “folders”. I mean these.

image

There are extra “Drafts” and “Trash” folders at the top, which need to be removed because they are using the wrong format (mbox instead of Maildir).

I’m only trying to remove the mbox folders, not the entire user. And by “folders” I do not mean filesystem directories, I mean these.

image

I have already removed the ~/mail directory from the filesystem, that is not my issue.

Usermin uses mbox format by default. I had to manually change it to Maildir and then I was left with this mess where there are mbox folders left over that I can’t delete.

Also: That screenshot is not “obfuscated”, I merely blacked out my username. If you must know, here is a full screenshot, with annotations.

Have to put this as a separate post, because in addition to Akismet deleting my posts instantly if they seem spammy, I can’t put more than one image in a post. Kind of annoying.

That’s wrong, if you used the Virtualmin install script. It should have switched Usermin to…I think IMAP? But it’s definitely not mbox, by default (it is in the Usermin package, but our install script changes it).

Anyway, did you change it in Webmin->Webmin->Usermin Configuration->Module Configuration->Read Mail or just in Usermin? Configuration options are limited for end users…most Usermin config happens in Webmin.

I don’t use Virtualmin.

Yes. In fact this is the only place you can change those options:

Ah, OK. Then, yeah, you’ll have to do it all manually.

I’m not sure why it won’t let you remove those folders, though…seems bug-like. I’ve made a ticket, and maybe Jamie has some thoughts on the subject.

That’s the point.

It looks like Usermin, by default, has special folders (such as Drafts) that cannot be removed. On its own, this is okay. However, these folders should be converted instead of duplicate folders added when you change the format from mbox to Maildir.

I don’t think this is an issue of not being able to delete the default folders. I think this is an issue of new folders being added instead of converting the old ones.