Cant receive email ?


I started off with clean Centos 5.2 Install (no apache, mysql, )

I downloaded the setup script and ran it. I do plan on registering this, just trying this out to get basic hang of it.

Once done, I updated my test domain to point to it.

I updated my godaddy dns record to point the the public shared ip

setup dmain as a virtual server

created a user
connected via local vtp and upload simple html page
can view it viw web browser on remote link.
When I try and send an email from Yahoo I get error :

<>: does not like recipient.
Remote host said: 554 5.7.1 <>: Relay access denied
Giving up on

Its obviously finding the host, but for some reason it does not see email.

Once this is resolved, need to get a better Webmail front end. My users are coming from a Cobalt Raq and are used to accessing web mail via mail.<their domain>/webmail

ANyway, thanks for reading this and any suggestions or help will be appreciated.

  • Lou


What do you see in the email logs, in /var/log/maillog?

Regarding webmail – by default, Usermin is available by going to

By editing the Server Template (Apache Website), you can make that webmail link go to any URL you like – it’s Usermin by default, but you could have it go to, say, a RoundCube installation.


I am able to remote pop the mailbox to see that I have email. However the maillog excerpt… below shows me trying to email myself from my yahoo account. Could it have something to do with how the account is named?

Jan 27 12:24:42 vhost postfix/master[30031]: daemon started – version 2.3.3, configuration /etc/postfix
Jan 27 12:25:05 vhost postfix/smtpd[30082]: connect from[]
Jan 27 12:25:05 vhost postfix/smtpd[30082]: NOQUEUE: reject: RCPT from[]: 554 5.7.1 <lou@sportcrm
.net>: Relay access denied; from=<> to=<> proto=SMTP helo=<>
Jan 27 12:25:05 vhost postfix/smtpd[30082]: disconnect from[]
Jan 27 12:25:11 vhost dovecot: pop3-login: Login: user=<lou.sportcrm>, method=PLAIN, rip=::ffff:, lip=::ffff:
Jan 27 12:25:11 vhost dovecot: POP3(lou.sportcrm): Disconnected: Logged out top=1/756, retr=0/0, del=0/1, size=1176
Jan 27 12:28:25 vhost postfix/anvil[30084]: statistics: max connection rate 1/60s for (smtp: at Jan 27 12:25:05
Jan 27 12:28:25 vhost postfix/anvil[30084]: statistics: max connection count 1 for (smtp: at Jan 27 12:25:05
Jan 27 12:28:25 vhost postfix/anvil[30084]: statistics: max cache size 1 at Jan 27 12:25:05

Hmm, interesting.

A couple of questions:

  • Can other users on your system receive emails?

  • If you log into your system over SSH, and run this:

cat /etc/fstab | mail -s "Test Message"

Does that email go through?

  • Also while logged in over SSH, what do you see when you type this:

host -a

To answer your question, I don’t think it’s the account name, but I’m not quite sure what the issue is ATM :slight_smile: Hopefully the above questions help point us in the right direction. Thanks!

I have only setup on initial test user to try email out at this time.

I logged in as root and used the command and root was able to send the message. I verified by using an RemotePop from a PC using the as mail host.

I am ssh’ing via vpn connection to the ip (.98) as root

I noticed that the DNS settings in server all contain the local machine IP, which hopefully are not a problem given that I NAT the public IP to the IP on my DMZ. Could it be a problem that the VM host is not registered? I could have an entry added to our DNS that resolves that name to the public ip .40 ?

Commands you requested are below :

[root@vhost ~]# host -a
Trying ""
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 5069
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 0, ADDITIONAL: 1


;; ANSWER SECTION: 38400 IN MX 5 38400 IN TXT "v=spf1 a mx ip4: ?all" 38400 IN SOA root.vhost 1233007056 10800 3600 604800 38400 38400 IN NS 38400 IN A


Received 218 bytes from in 1 ms

>Host has address

I updated my spf record at GoDaddy to see if that makes an difference.
Will have my domain admin add an A record to for vhost

  • Lou

I was looking around and saw a DNS setting in VirtualMIN

IP address for use in DNS records Same as real address ( I changed it to the public IP .40 address and mail still not coming in.

Hopefully this is just part of tweaking the installation. My goal is to replace an aging Sun Cobalt Raq with Centos 5/Virtual Min on a new dell server I have.

  • Lou

Also tried simple sMTP test using the Local IP as SMTP server to send email to yahoo.

My guess is that the two may or may not be related.

Jan 28 01:09:23 vhost postfix/anvil[12881]: statistics: max connection rate 1/60s for (smtp: at Jan 28 01:06:03
Jan 28 01:09:23 vhost postfix/anvil[12881]: statistics: max connection count 1 for (smtp: at Jan 28 01:06:03
Jan 28 01:09:23 vhost postfix/anvil[12881]: statistics: max cache size 1 at Jan 28 01:06:03
Jan 28 01:12:18 vhost postfix/smtpd[13000]: connect from unknown[]
Jan 28 01:12:19 vhost postfix/smtpd[13000]: NOQUEUE: reject: RCPT from unknown[]: 554 5.7.1 <>: Relay access denied;
from=<> to=<> proto=SMTP helo=<LATLOU>
Jan 28 01:12:19 vhost postfix/smtpd[13000]: disconnect from unknown[]

Yeah, this last one is probably due to not having your email client authenticate to the mail server when you’re sending email.

YEp… I can send but I stil am not able to receive emails. Tried from another server

Failed to deliver to ‘’
SMTP module(domain @| reports:
host says:
554 5.7.1 <>: Relay access denied

I will check back here again later today. IF there is anything else I need to try let me know. I could also arrange for someone to get remote access to my desktop and then ssh into box from there, but that is a last resort. I may try building another VM and see if same problem persists.

  • Lou

My guess is that with your host on NAT behind a router, that some IP’s aren’t setup as they need to be.

Does it sound correct that the internal IP address of your server would be

Any idea what the IP address is that’s in your latest message above?


The ip was me sending an email out from my office where that mail server to functions behind a NAT’d IP (Communigate Pro). I have 250 users sending email through that box daily and its just how it error’d back to me.

Yes is my Private IP on my DMZ network which is NAT’d to the .40 public ip.

Do most users just expose the server to public internet? I have always nat’d my servers only opening the required ports.

Is there some kind of diagnostic I can provide. Could it be something in the DNS on the Virtualmin host itself?

I will be able to access it again later tongiht.

I really do appreciate all the input on this.

  • Lou

Hi Lou,

I can’t say that not being on a NAT’d connection would solve the problem. I’m not quite sure what the issue is.

But, it would rule out a whole host of possible issues :slight_smile:

To answer your question, I do think most folks run Virtualmin on a public server, and that’s certainly the easiest way to set it up. That’s what I do, but I run firewall software on the server itself, and only open up ports that need to be available.

However, it should work either way.

Does /etc/postfix/ have a virtual_alias_maps line such as this:

virtual_alias_maps = hash:/etc/postfix/virtual

and, does /etc/postfix/virtual have a line such as:

Not having that could make Postfix think it’s not the destination for that domain.

/etc/postfix/ did contain virtual_alias_maps = hash:/etc/postfix/virtual

the virutal file did not haveportcrm

so i added

saved, restarted services and still no inbound email


Well, when you edit that file, to actually update the DB, you’d have to run this:

postmap /etc/postfix/virtual

and then at the point, you can restart:

/etc/init.d/postfix restart

Does that help?

Success! That did it.

So, now I know. I need to edit that file every time I add a virtual host.

Is this a bug? Will it be updated in future update?

Thanks for all your help.

  • Lou

No! Don’t settle for editing that file, this problem should never happen :slight_smile:

We’re just determining the issue - the next step is to figure out if it was a fluke, or if there’s something preventing it from being added correctly.

If it’s a bug, Jamie will fix it.

The next step is to figure that out, though.

Do you have a new Virtual Server (domain) you can add? Even if it’s just a dummy one that you delete?

I’d love to know if that line gets added the next time around.

Hi … Yes I have several domains parked. I will go ahead and make the DNS changes on one of them and add it to Virtualmin in the morning and report back hear as to what I observe.

I will also probably try installing VirutalMin into a new linux VM running Centos 5.2 again

  • Lou

Good results this time.

I add a new domain and the entry was added to the virtual file.

I was able to email a user from yahoo, so looks like it was fluke. I will confirm after I do a clean re-install and repeat the process adding the same first domain and then the second.

Thanks for all the help.

  • Lou

That’s great news Lou, thanks for the update!

i’m having the same problem,i cant recieve emails, but i can send them, however i checked my virtual file and it contained the entry but i still cant get emails. i’m running ubuntu 8.04, and my ip is dynamic i think though it doesnt get changed very often. for my dns i’m using godaddy since i have a domain from them, i created an A record pointing to my IP IN A x.x.x.x

and then i created MX record pointing to A record IN MX

i’m forwarding ports 110, 25 and 143 to my virtualmin box.

when i try to send email to email from yahoo i get the following errors does not like recipient.
Remote host said: 550 sorry, mail to that recipient is not accepted (#5.7.1)
Giving up on

and is not my ip.

any help will be greatly appreciated…