Can't login to webmin as a user under

Hello Everyone,

I have Webmin running with multiple users/virtual servers on it.
Some of the servers I checked the Create Webmin login?
But when navigating to I don’t get the login page, just a connection timed out error.

Do any other settings need to be done in order to have a user login to that particular virtual server?

Thank you.

1 Like

No other settings need to be changed - if the virtual server is serving the website when the domain is entered in the browser, then domain.tld:1000 will work without you needing to do anything more.

Run the following:

sudo service webmin restart

If this does not throw an error, check if ports 10000 - 10100 are open in your vps firewall.

Thanks for your reply @calport.
Running this sudo service webmin restart did not give me an error.

I’ve checked the CSF settings and added port 10000 under:
Allow incoming TCP ports and Allow outgoing TCP ports

But the issue remains, I get connection timed out.

10000 - 10100 should be open in your VPS firewall

I added to Allow incoming TCP ports and Allow outgoing TCP ports the following: 10000:10100

Still the same.

Aside from local firewall (on your server), there might be internet service provider’s firewall (familiar to GCP, for instance), which may also block your traffic. It may be DNS issue as well. Try connecting to your server using IP address, like IP:10000.

Just a note here, only port 10000 is needed for the UI. The additional ports are needed for interprocess communication with other Webmin systems (so, for DNS secondaries, Cloudmin, etc.).

I have the same issue as well. When I installed, I didn’t have a working FQDN so I just used one that I didn’t own. I’m confident I have made all the proper changes but like you when I go to IP:10000 no problems when I go to domain.tld:10000 I get a can’t connect. The same for usermin IP:20000 no issues; domain.tld:20000 I get a can’t reach error.

I tried doing the

?sudo virtualmin modify-web --all-domains --no-webmail
?sudo virtualmin modify-web --all-domains --webmail

Thinking this would fix it but it didn’t.

Maybe there is some other option I should be trying with the virtualmin modify-web command

This is not related to your problem at all.

Your DNS is just wrong. If Webmin/Usermin answer when you enter the IP but not when you use the domain, it means your domain name does not point to the IP of the Webmin/Usermin server. Check to be sure your domain actually resolves to the IP of the server (use host or dig). If it doesn’t, you need to fix it in your DNS, wherever it is hosted.

the host command displays my IP for each of my tld domains that I enter. The websites all function without issue so my DNS record has to be pointed to my IP.

Thanks for everyone trying to help here.
I found out that for me the issue is using cloudflare…when I removed the proxy from cloudflare I am able to get the virtualmin login screen to come up.
Not sure if there is a way to get this to work with the proxy enabled but at least I know what caused the issue.

Ask Cloudflare to allow port 10000 and 20000 for Webmin/Usermin. We can’t fix it. They apparently allow forwarding some other ports for other control panels, but not Webmin.

Thank you. I am using cloudflare as well. This answers my question.

Also, you can switch Webmin and Usermin to run under a different port (one that is allowed by Cloudflare), but probably easiest just to setup one domain specifically for administrative access and don’t run it through Cloudflare. I don’t think I’d want an intermediary in between me and my administrative UI, anyway.

This topic was automatically closed 4 days after the last reply. New replies are no longer allowed.