Can't get to the VM via VNC, but better Graphical Console required for years now :)

OS type and version Debian 11.2
Webmin version 1.984
Cloudmin version 9.6 Pro

Seems like after latest update something changed in regards to the Graphical Console. As there still is no integrated option that works, at least for me, I was using an external client, namely KRDC. It was working OKish, but at least it was clear that one of the ports above 5900 should be used and what was the password, displayed bellow the eternal errors, when I clicked Cloudmin > System State > Graphical Console. Now I get something like:

If the VNC client does not run or cannot connect, you can use a separate VNC client to connect to port instead, and login with password XXXYYYZZ .port= wsport=5700

Tried opening all the ports above 5700 also (what is that “wsport” ?), but there is nothing now in the “port=” and it doesn’t work on any of the 5900 range, with “Server not found” in the client.

This should be rock solid, it is essential. Please tell me how to fix this, as I am stuck at reinstalling a DNS server, and can’t get to the installer in the VM.

Later edit: after reviewing the configuration, restarts and such, in the end it worked as before the port being 5900, don’t know why. Can’t we make that whole section simple and functional as it is pretty important? I mean why is there flash and java and stuff that doesn’t work, just print a consistent, clear message… ?


I don’t think VM deals with VNC or similar directly. VM does have a JavaScript console built into the panel which does a pretty good job however.

It is also not advised to run a server on an OS with a graphical UI if that’s what you are doing.

Not the VM - Cloudmin, at the location stated, and no GUI on my servers. It is not about VNC “in a VM” but to it so you are able to install stuff, interact, when no other network connection possible, or when dealing with a ruined fs.

Oh … it looks like the port is missing entirely from that message.

What kind of VM is this? KVM, or Xen?

Hello Jamie and thank you for answering! It is a KVM host and a KVM VM, both with Debian 11.2. Well… the VM couldn’t be in fact installed because of the problem, couldn’t get to the installer.

The Cloudmin master is also on Debian 11.2, everything updated. But in the end it worked, don’t know why, probably the restarts?

Make sure that on the graphical console page, that “Flash” mode is selected. Otherwise, a VNC port won’t be assigned, and due to a bug that message is shown incorrectly…

@Jamie - is this a bug introduced in version 9.6?


I know the drill, clicked everything there is, message was exactly the same - without the port (maybe due to the update) and it started after reboots. Curious is I restarted Webmin everywhere immediately…

Did this stop working after rebooting the VM, or the host system?

An unfortunate explanation on my side, should have write “and it started WORKING after THE reboots”.

So now it is fine, because it started working after I rebooted everything, Cloudmin master, the hosts, and the VMs.

Ok, great! I wonder why though …

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.