Can't enable SSL???

I have an existing virtual server that is using the system shared address on Virtualmin PRO. So, user now wants a SSL certificate, so, I thought I would be able to go into edit virtual server, under configurable settings ((I’d swear I saw that before…) and change to dedicated IP, but, no option is available.

Under virtual interface, it says "No free IPs are left in the allocation range" which may have something to do with the problem…??

I can instead go to enabled features and select SSL, but, then I get a warning that the server needs a virtual IP, which is what I wanted to do in the first place.

If I look under server templates, I see that I have defined a range of address that can be used, and, are not in use.

So, confused! How to change the server?


If you go into Edit Virtual Server -> Configurable settings, you can set a private IP for the Virtual Server by setting the "virtual interface" field.

Actually, I can’t. The virtual interface field is disabled, it says none, and, as my post said:

"No free IPs are left in the allocation range" which I think its the key. The question is, WHy does it say this as I have lots of unused IPs, and, my allocation range IS set.

If I change the allocation range to NONE, then, it allows me to type an IP. I thought it was the exact opposite of what was supposed to happen??? After all, the doc says:

"Ranges for automatic IP allocation

If SSL or FTP virtual hosts will be created using this template, you may specify a range of IP addresses to allocate from. Both SSL and FTP virtual hosts require a dedicated IP address, because neither supports name-based virtual hosting."

So, set to none, it DOES allow me to manually set an address.

If I retype in the range I want to use, it then goes back to the behavior I originally asked about.