Can't create transaction lock on /var/lib/rpm/.rpm.lock error on fresh Rocky Linux 9

OS type and version Rocky Linux 9
Virtualmin version 7.1.1

Hello all,

I am trying to install virtualmin latest version on brand new fresh installed Rocky Linux 9 but I am always getting error no matter what I tried for several hours. I read everything in the forum, searched for the similar issue, tried many things and still the issue is the same. Can someone suggest what to do?

Welcome to the Virtualmin GPL installer, version 7.1.1

This script must be run on a freshly installed supported OS. It does not
perform updates or upgrades (use your system package manager) or license
changes (use the “virtualmin change-license” command).

The systems currently supported by the install script are:

Red Hat Enterprise Linux and derivatives
  - RHEL 8 and 9 on x86_64
  - Alma and Rocky 8 and 9 on x86_64
  - CentOS 7 on x86_64

Debian Linux and derivatives
  - Debian 10, 11 and 12 on i386 and amd64
  - Ubuntu 20.04 LTS and 22.04 LTS on i386 and amd64

If your OS/version/arch is not listed, installation will fail. More
details about the systems supported by the script can be found here:

The selected package bundle is LAMP and the size of install is
full. It will require up to 2 GB of disk space.

Exit and re-run this script with --help flag to see available options.

Continue? (y/n) y
[INFO] Started installation log in /root/virtualmin-install.log
▣:white_medium_square::white_medium_square::white_medium_square: Phase 1 of 4: Check
Checking system time :heavy_check_mark:
Checking Perl installation :heavy_check_mark:
Checking CA certificates package :heavy_check_mark:
Checking HTTP client :heavy_check_mark:
Checking GPG package :heavy_check_mark:

▣▣:white_medium_square::white_medium_square: Phase 2 of 4: Setup
Installing core plugins for package manager :heavy_check_mark:
Downloading Virtualmin 7 release package :heavy_check_mark:
Installing Virtualmin 7 release package :heavy_check_mark:

▣▣▣◻ Phase 3 of 4: Installation
Installing EPEL release package [ERROR] Failed with error: 1

[ERROR] Something went wrong. Exiting.
[ERROR] The last few log entries were:
warning: virtualmin-gpl-release.noarch.rpm: Header V4 RSA/SHA256 Signature, key ID b9a0b8b7: NOKEY
error: can’t create transaction lock on /var/lib/rpm/.rpm.lock (Resource temporarily unavailable)
error: /etc/pki/rpm-gpg/RPM-GPG-KEY-webmin: key 1 import failed.
error: can’t create transaction lock on /var/lib/rpm/.rpm.lock (Resource temporarily unavailable)
error: /etc/pki/rpm-gpg/RPM-GPG-KEY-virtualmin-7: key 1 import failed.
Installing Virtualmin 7 release package: Success.
[2023-08-26 07:21:45 UTC] [DEBUG] Phase 3 of 4: Installation
Spin pid is: 2426
Virtualmin 7 - aarch64 1.0 kB/s | 234 B 00:00
Errors during downloading metadata for repository ‘virtualmin’:

  • Status code: 404 for (IP: x)
    Error: Failed to download metadata for repo ‘virtualmin’: Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried
    Installing EPEL release package: [2023-08-26 07:21:47 UTC] [ERROR] Failed with error: 1
    [2023-08-26 07:21:47 UTC] [ERROR] Something went wrong. Exiting.
    [2023-08-26 07:21:47 UTC] [ERROR] The last few log entries were:

I really didn’t find anything useful in internet which to help me…
Thank you in advance for!

That is not a supported architecture.

Our supported distros are listed here OS Support – Virtualmin as well as when you first run the install script.

You can make it install and run on ARM pretty easily, but you’ll be missing mail features. If you search the forum, you’ll find extensive discussion about it. If you plan to use it in production and you aren’t extremely experienced with your OS and with all the services you’ll be using, I recommend you pick a supported OS on a supported architecture.

Jesus, thank you!
I am using Hetzner Cloud and didn’t saw that my server is on ARM64. I will probably create a new server on x86 arch.

I really appreciate your help!

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.