Can't create backup

AlmaLinux 9.3 AlmaLinux 9.3
Virtualmin version 7.9.0


I’ve setup a new VPS on a different provider and want to move my virtual servers from host A to B.
On host A I’m trying to create a backup of the domains I want to move. But for some reason this fails with error “no domains selected”.

I’m doing this via Virtualmin > Backup Virtual servers
I’ve selected the domains I want to export first. Leave “all features” in place and give a folder on my vps as the destionation (/home/backup/export)

Once I press “Backup Now” it shows the error.

I also have 2 scheduled backup jobs (setup when I configured the server initially) which are still running fine. I’ve tried cloning the full-backup-scheduled-job and adjust it (selec the virtual servers + change destination) but that gives the same error…

thanks in advance for your support

What exactly do you mean by “different provider”?

I’ts currently hosted with VPS provider A and I’m moving to a competitor with a better offer

Ah I think what you are saying is that the provider of your VM (the actual box) like for example Digital Ocean or Akamai/Linode or Hostinger et al

And you have Virtualmin (7.9.0) installed on each of these providers A and B.

Both using the same OS (Alma Linux 9.3) ?

or is box A using some other system? I cannot see a problem backing up a specific domain in Virtualmin -> Backup Virtual Servers seems to work just fine here.

If you have scheduled backups running I can se they might just clash (but wouldn’t expect them to - in which case stop them and try again)

Why not use the domain transfer option ?

Regardless of the method the user chooses to use to migrate the domains, this seems to be a problem that needs solved.

1 Like

I don’t think the transfer option has been tried

@Walter81 I just tired this. Have you double clicked on a server to move it to the right hand window? I just tried and this is the method. You can’t use keyboard select in the left window to highlight the ones you want.

1 Like

My point isn’t about how to transfer and move the domains. They must still be able to use the backup feature. I think it is user error and not system error at this point after trying though.

:man_facepalming: this was it. Seems a massive blind spot on my side. Thanks!!! (so the error did make sense after all)

Yeah. First time I tried it I was only going to backup one domain as a test so I clicked on it and tried to do the backup. I ended up getting the same error as you. Not like they aren’t all grayed out, but, when you know Ctl Click and Shift Click keyboard commands you get tunnel vision I suppose.

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.