Can't create a new virtual server.

For some reason I can’t create a new virtual server… I get this error.

Failed to create virtual server : DBI connect failed : Access denied for user ‘root’@‘localhost’ (using password: YES)

Also when webmin tries to update to the newest version it says Access denied for user ‘root’@‘localhost’ (using password: YES) also.

What could be the cause of this problem?

Sounds like the incorrect MySQL password is listed in there for the admin user.

Try running System Settings -> Re-Check Config, and have it run through and make sure things look correct… and if not, you may need to correct them.


My root mysql user has no password, every time i try to log in to mysql via command line and change the password it says access denied for user ‘’@localhost like I’m not using a username. I try to change it from the virtualmin interface and the same result happens.

Can I please get some help :slight_smile: Thanks.

in webmin-servers-mysql database server and then click in the right screen at the top on module config.
do you see: Administration login Automatic
Administration password Don’t change Set to?

what if you changed Administration Login from automatic to root and then set a password?

My root username has no password… that’s the problem. I dont know how to give my root username a password either.
I tried what you said and it didn’t work. always said failed to connect with username pass.