Can't connect to virtualmin:10000 after reboot.

Can’t connect to virtualmin:10000 after reboot.

After a fresh install ubuntu 10.04 lts + virtualmin everything seems te be working. I can connect to virtualmin by browsing to https//:10000.

The weird thing is, after reboot virtualmin is not reachable anymore.

Error on firefox :
Firefox can’t establish a connection to the server at :10000.

Listing iptables, all ports are open.
sudo iptables -L

Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

I’ve already tried atleast 6 fresh install of ubuntu + virtualmin. Same result everytime. After reboot, I can’t connect to virtualmin.

Does anyone have this same problem?

It sounds like you might be seeing the Ubuntu startup script bug… Virtualmin may simply not be starting up properly.

A quick fix is just to launch it manually:

/etc/init.d/webmin start

There’s a forum thread about that here:

The way to resolve so it starts up next time is to run this command:

update-rc.d webmin defaults

You’re right!

“update-rc.d webmin defaults” did the trick.



I still have connection issues after clean installation of Virtualmin. I ran the provided command but it didn;t do the trick.

Any ideas why?


What is the output of this command:

netstat -an | grep :10000

Also, what error are you receiving in you browser when trying to connect to port 10000?


Hello Eric,

Thanks for taking the time to reply. I already figured it out. I can swear I enabled the port 10000 but apparently I hadn’t. That was the whole problem.