Cannot write to directory /etc/webmin/virtual-server/ (extra text for dupe title)

SYSTEM INFORMATION
OS type and version Rocky Linux 8.6
Webmin version 1.994
Virtualmin version 7.1 Pro

So the system rebooted at about 9:30 a.m. I don’t know why yet. It may have been a node reboot. I’m looking into it.

At the time, it may have been in the process of migrating a cPanel backup as a test. That failed without an error several times, and then seemed to complete, but without any features enabled at all on the migrated site.

The system them gave me a warning that the configuration hadn’t been checked since the most recent update (there was no update that I know of). Running the configuration check results in the error

The feature *Administration user* cannot be disabled, as it is used by the following virtual servers :

followed by the two previously created virtual servers (which are still working, oddly enough).

Next the system went into post-install configuration, again for reasons unknown at this time. When it got to the plain text / hashed password option, it returned the error

Cannot write to directory /etc/webmin/virtual-server/

Which also comes up when I attempt to fix things using suggestions in previous posts of this nature.

The dashboard also isn’t working in either Webmin or Virtualmin.

Any ideas?

Thanks,

Richard

I’m having this same issue and I’m not sure what to do. Were you able to find a solution @RJM_Web_Design ? please let me know

I wound up reinstalling the OS and Virtualmin because there were other things going on at the same time that made it impossible to diagnose the problem, and the server wasn’t in production status anyway.

Were you migrating a cPanel site when the problem occurred?

Richard

No, unfortunately this server has been in use for a couple of years now. I think it must have happened after an update, but I’m not 100% sure on the timing.

vultr docs recommend: don’t use “Work out from backup” - this feature is known to almost always fail.

maybe this is a old bug. docs are old Last Updated: Fri, Mar 6, 2015

If you mean on the password, no, it wasn’t that. I may have ticked that option for the username, however.

Yep, not sure thats your issue anyway.

Steve