Cannot start service on port 10000

Hi, I have been testing a few web hosting software, and virtualmin/webmin looks the most promising! But after installing, I cannot get the dashboard to be displayed through port 10000. My system is running on CentOS 7, with a minimum configuration. This is what I have tried, after reading most of the post for proposed solutions:

  1. Visit browser page
    When I visit https:my.ip.adress:10000, no connection.
    When I visit http:my.ip.adress, there is a page with the heading Index of /, with no files listed.

  2. Restart
    service webmin restart

Webmin server stopping and starting without warnings

3 )Check if port 1000 is open

netstat -an | grep :10000

tcp 0 0* LISTEN

udp 0 0*

  1. Visit page with SSH

link https://localhost:10000

Unable to retrieve https://localhost:10000/:
Connection refused

  1. Check error log

cat /var/webmin/miniserv.error

The only significant error is the Perl Authen PAM module that is not installed, but this does not seem to prerequisite from previous comment.

  1. Reboot

No difference.

Do not know how to troubleshoot this further. Any help will be appreciated.


I’m glad I was able to assist you with getting things sorted out. If you require any further assistance in the future, feel free to drop me a line on Skype or by email.

Best Regards, Peter Knowles TPN Solutions

Phone: +1-604-782-9342
Skype: tpnassist

Ok, the issue is solved with the help of Peter! I had to open port 10000 on my cloud control panel as well.