Cannot send mail using outlook or iphone

Using sendmail, I can receive email using both outlook and iphone, but cannot send using either.

I verified, port 25 is open, and sendmail is functioning properly on the server (have had a website on there running for months).

I had a blackberry before and never had any problems. It appears the iphone and blackberry use different functions for actually sending the mail, thus my issue is only now appearing.

Do I need to setup a relay or something to get this to work? I’m sure its simple, please help!


Well, Sendmail isn’t really my area of expertise (I’m more of a Postfix guy) – however, what error do you get when attempting to send an email?

Do you see any errors or warnings in your email logs, /var/log/maillog or /var/log/mail.log?


Thanks for the quick response!

No, no errors at all. Timeout in the client. I tried switching to postfix, but nothing was listening on port 25. (did the switch in system config, in read user mail module, and did “alternatives --config mta”)

I’m sending the email via outlook/iphone, they just hang when attempting to connect to my server on port 25, even though the port is open and i can telnet to it (from an outside server).


Wow, it turns out that AUTH LOGIN is NOT enabled by default in sendmail. The iphone supports MD5 Digest, which worked on port 587! I cannot get it to work on port 25 or port 465, and I can’t get it to work in SSL mode.

I don’t really care that outlook isn’t working, so all is well in that arena. However, how would I get SSL to work? And why won’t port 25 work?



One thing you may want to try is to see if it’s listening on port 465. I’m not sure about Sendmail, but Postfix doesn’t listen there by default.

You can see if anything is listening on port 465 by running this command:

netstat -an | grep :465

As far as why port 25 isn’t working – some ISP’s block port access to port 25 in order to cut down on spam, requiring you to use port 465 or 587. It’s possible that’s the case.

It sounds like you’re saying port 25 is otherwise working just fine on your system, so if you’re getting timeouts when connecting to it via an email client, and seeing no message in the log, my bet is that it’s an ISP issue :slight_smile:


Port 465 is open using netstat, but can’t get it to connect with outlook or iphone, like its timing out (nothing in maillog). Moreover, can’t quickly trouble shoot with outlook due to the restricted available AUTH types. And apparently you have to rebuild sendmail to enable login as well??? So not worth it to me …

Ports 465 and 587 weren’t available by default, I had to uncomment lines in the M4 configuration, rebuild and then restart. I only figured out LOGIN wasn’t available by testing on the port using telnet.

Anyway, I’m happy to just be able to have something working. Maybe I’ll revisit the security sometime later. At least I have something, eh? Damn new phone, can’t believe how archaic its email support is, what’s up apple?

Thanks for trying. BTW, is there an approved by you tutorial on how to switch a system over to postfix from sendmail? I set my system up for the first time with you folks using virtualmin, why was it sendmail initially when it sounds like several of your previous posts are saying postfix is the default. Was it changed since 3 years ago? I can’t imagine me changing the default back then.


Well, with that netstat output, you’d want to make sure it was listening on an external interface.

If it is, there may be a firewall that’s blocking port 465. Is your server running a firewall by chance? Or is there a router in front of it that could be blocking that port?

As far as switching from Sendmail to Postfix – there isn’t a way to do that which would migrate any accounts you’ve already created. So after performing a switch, you’d need to do some manual configuration if you already have existing email accounts / aliases.

A new installation on a fresh install would automatically switch to Postfix.

You can switch using the method you had tried above… and then, if it doesn’t work, the key would just be to take a peek in the mail log to figure out what the issue is. If you aren’t familiar with the error you see in there, feel free to paste it in here and we can get it figured out :slight_smile: