Cannot restart network interface after adding second IP address

Hi all,
I add my 2nd IP in virtualmin and i ran the command

service networking restart

I got error

Job for networking.service failed because the control process exited with error code.
See “systemctl status networking.service” and “journalctl -xe” for details.

What’s going on?

The answer could be had if you run
systemctl status networking.service

I got this error for that command

It says: unknown interface conf. Let’s start at the beginning. Tell us how exactly you added the second IP address to Virtualmin.

1 Like

@calport Please check the images

What distro/version? There are huge network differences across all of them.

1 Like

Its Debian 10

Anyone can help me please.

Not sure who you’re hosted with for this server? I ran in to all kinds of issues with AWS and attaching a 2nd IP addy to the primary network interface, to the point that I gave up.

Every reboot would remove the 2nd IP addy from the network adapter. I know it can be done, but it was more trouble than it was worth. The only issue I see in your network config (perhaps?) is your eth0:0 designation, for the virtual adapter name.

Good luck on this, I threw in the towel and gave up, as it didn’t seem to be worth the trouble to research it enough to make it work correctly.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.