Cannot log in to Vmin

2 days ago I was able to log into the server using http://~domain_name~:10000 and Vmin worked fine. Today all I get is a server time-out. Tried many times with no result. As it is a while since I last ran a YUM update I did so and then restarted the server (update included a Kernel update) but still could not log into Vmin. The miniserver seems to be running:
[[root@ns1 ~]]# ps aux |grep miniserv
root 2854 0.0 9.8 105648 100592 ? Ss 19:54 0:00 /usr/bin/perl /usr/libexec/webmin/ /etc/webmin/miniserv.conf
root 2860 0.0 0.5 10596 5544 ? Ss 19:54 0:00 /usr/bin/perl /usr/libexec/usermin/ /etc/usermin/miniserv.conf
root 3077 0.0 0.0 3912 676 pts/0 S+ 20:01 0:00 grep miniserv

So restarted Vmin using both methods you gave in response to another question:
[[root@ns1 ~]]# /etc/init.d/webmin restart
Still no response
[[root@ns1 ~]]# killall
[[root@ns1 ~]]# /etc/init.d/webmin start
[[root@ns1 ~]]# /etc/init.d/usermin start
and still no response - just the same time-out in Firefox.

What should I try now. All other services, BIND, HTTPD etc appear to work OK, just can’t get to Vmin/Webmin or Usermin

Hey Richard,

Sounds like your firewall is blocking port 10000.

You can try connecting locally using lynx or links to see if this is the case. On the server itself:

lynx https://localhost:10000

Hi Joe,
Thanks very much for that - you hit the nail on the head.
No Accept rule for port 10000.
Added a new rule and it worked
I don’t suppose you have any idea how the Accept rules for ports 10000 and 20000 could have been deleted, I didn’t do it and there is no sign in the logs for someone else to have logged onto the system and chkrootkit does not identify any altered files.

Hey Richard,

Two things I’ve seen lead to this situation.

You’re running some third party firewall script like APF, which does not respect the system firewall rules.

You’ve fired up whatever firewall configuration tool came with your OS. Even if you didn’t do anything with it, it may very well have blown away the system firewall rules.

Unlike Webmin, the vast majority of system configuration tools out in the wild do not respect existing configurations and store their own private set of data…which they then blast out with no regard for what was there before. This seems to be especially true for firewall utilities. I’m not sure why this is so, given that most Linux distributions provide standard locations and tools for managing the firewall rules file. It doesn’t make sense to do things outside of it…but so many people do, it’s really very frustrating. It seems to me that firewall rules should be pretty sacred, and one shouldn’t mess about with them if you aren’t being polite to existing rules.

In case you haven’t noticed, I don’t particularly recommend most firewall tools for Linux. I’m certain there are some out there that respect existing configuration files…but I don’t know of any other than Webmin’s Linux Firewall module.

Hi John,
Both “links” and the newer “lynx” are text only web browsers which run in UNIX/Linux. Most linux distributions include one or both in the standard installation and you should have one or the other on your server. If not you should be able to easily install one using YUM, APT or RPM depending on your O/S.
Both are cumbersome to use if you are not familiar with them especially when looking at a web page such as that produced by Webmin/Virtualmin however both will allow you to make changes to the server config files. lynx is probably a bit easier to get to grips with. I’d recommend installing one on a local PC first and using it to browse the web to get a bit of familiarity before trying to run it through SSL on your server - just so that you learn how the navigation works. Both have quite good help documentation on their respective web sites:
links -
lynx -
Don’t forget that you have to run your chosen one on the server itself (console or through SSL); because if you try to access webmin with one of these browsers remotely you will have the same problem with the firewall blocking as you do using a graphics browser (like firefox).
Hope this helps

Hi Richard,

Joe said:

Hey Richard,
Sounds like your firewall is blocking port 10000.
You can try connecting locally using lynx or links to see if this is the case. On the server itself:
lynx https://localhost:10000
Posted by Joe Cooper

This is my PRECISE problem/experience.
wot is lynx?
I just looked it up via google and didn’t even understand the explanation! :-{
It appears to be a specific program requiring a lot of knowhow to get it onto a Server, with a lot of caveats…

How does one access it?
(Note: This is the NEWBIES section after all!! :slight_smile: )