Cannot Log In as Ubuntu User

I have successfully installed Ubuntu 12.04.2 LTS, followed by a successful install of Webmin/Virtualmin using the script. Everything worked fine, and I was able to log in to Webmin using my Ubuntu user account (which is able to use sudo).

After installation, I realized I had munged up my disk partitioning, and not created the RAID array they way I had intended. Since this is a new install, without any data, the easiest thing was to simply re-install everything.

During this installation of Webmin/Virtualmin, my router crashed, and I lost network access. No problem, I thought, and as soon as the router was back up, in re-started the script.

However, this time I am unable to log into Webmin using my Ubuntu account. I am able to log in using the Webmin root user account. I have tried to modify all the settings in the Webmin Users module to allow system users to log in. Doesn’t matter what I do, whether I list them individually, or as a group and say allow, Webmin won’t let me use a system user account to log in.

I figure that some file was likely corrupted in my installation. Any idea if this is easily fixable, or should I just wipe the system clean and reinstall again? I’m thinking that I should just re-install, to ensure that nothing else was munged up.


Hmm, that’s an odd one… so you’re saying that you can log in as root – but if you create a Virtual Server using Virtualmin, you can’t log into Webmin using the Virtual Server owner that’s created with that new Virtual Server?

And just to verify – if you look in Edit Virtual Server -> Enabled Features, is the “Webmin Login” feature enabled?


Eric, I think the OP is trying to log in to webmin as a Linux user (without having a specific Webmin user), independently from what Virtualmin creates. @NeuroDoc, does Webmin record anything in the syslog (/var/log/syslog) at the time of login attempt? Webmin can also write a debug log, which you can turn on at “Webmin / Configuration / Debug Logging”. Its contents might help finding out what the issue is.


Correct. I cannot log into Webming using a system user’s credentials. Only using credentials for the Webmin root user. I did create other webmin users, and could log in using those credentials without problem. I also created additional system users in the linux system, but could not log into Webmin using any of those.

There is nothing recorded by Webmin in the syslog.

However, I am seeing a ton of network error messages in the syslog, which leads me to believe that more than just Webmin log in was affected. Time to reinstall. Thanks for the help.

A reinstall of the system and Virtualmin/Webmin has fixed this error and appears to be working like a charm.