Cannot ftp login.

I setup a virtualmin server successfully on an amazon ec2 instance using the guide

Now i created a new user say XYZ with my new virtual server, now to add my website wiles i need to upload it into this folder.

Now i can only login through sftp from a client say filezilla through a key that i recieved from amazon the user being ubuntu for an ubuntu server.
After this i do see two user folders i.e ubuntu and XYZ but i do not have permission to access the XYZ folder which have my web files.

Also it is not possible for me to login using the XYZ user.

Please help me troubleshoot this problem. I need to set up me website as soon as possible.


Are you able to login and access the files as the Virtual Server owner?

The files within the website may be owned by the Virtual Server owner… it’s possible that another user wouldn’t have rights to those, depending on how the user was created.


Yes i just realized i needed to login as virtual server owner and it all worked well.
Just that now i encountered with a new problem.
When i click on recheck configuration now i get the following error.

Your Postfix configuration is missing the system’s mail hostname ip-****** from the mydestination line, which will cause mail to bounce.

… your system is not ready for use by Virtualmin.

Can you please also help me with this?

Resolved the other said error by adding my ip along with the domain in the file.

Now i have another issue.
I installed roundcube and everything worked fine.
Then i configured the password plugin using this guide.

Every thing worked fine but when i logged into roundcube and tried changing the password it gave me an error saying new password could not be saved.
I checked the error logs and it said this,

PHP Error: Password plugin: Unable to execute /home/USERNAME/public_html/roundcube/plugins/password/helpers/chgvirtualminpasswd in /home/USERNAME/public_html/roundcube/plugins/password/drivers/virtualmin.php on line 87 (POST /roundcube/?_task=settings&_action=plugin.password-save?_task=&_action=)

What is the reason for this? I got no errors in following the above guide.

Please could you help me out with this last thing.


Okay i finally got the above error fixed.

I am just sharing how for others who might have the same problem.

The above guide is for an older version of roundcube and that is why setting it up with a newer version might create problems.
What i did was i completely uninstalled roundcube and then reinstalled the script of an older version which is 0.8.7 available in auto install of virtualmin.

Then i setup the password plugin exactly using the above guide and it worked perfectly for me.

After that i simple went back again to auto install scripts and upgraded my roundcube version and everything worked fine for me without any errors.

Sorry for bothering but i just got through this easy solution while trying to fix the problem.