Cannot find Linux Firewall

OS type and version Ubuntu Linux 22.04.2
Webmin version 2.021
Virtualmin version 7.7
Related packages SUGGESTED

I’m a GPL user in Virtualmin. I installed Ubuntu v22 and latest version of Virtualmin on my server. I need to access Linux firewall, but i can’t find it in this directory webmin/networking/…

I can see only FirewallD.

Looking for your help.
Thank you.

Thats correct, VM uses FirewallD.

I’d like to change the ssh port on my panel. I changed it in webmin/servers/sshserver/edit config files.

Unfortunately, I can’t log in to my server via ssh after port changing.

I even added my custom port as allowed one in FirewallD and Usermin Cofiguration, but that’s not working too.

I learned from other topics that I can fix this through Linux Firewall. But I do not have access to it.

Can you help me solve my problem?
Thank you friend.

so did you apply the config after adding the new port in firewalld

Yes I did, that’s not working too.

I added my port as single port, it isn’t available to add it as service.

I even disabled my FirewallD, I still cannot connect.

Well that not a firewallD issue :slight_smile:

how did you change to the port in sshd?
Just here?

this will show if its listening on the port
lsof -i:22 change to new port

I changed it here. but it is changed in Networking too.

try lsof -i:2724

or watch it
watch lsof -i:2724

Do you mean running this command on terminal?

lsof -i:2724

what the miniserv, maybe that a conflict

Why has the OP got webmin running on the same port ? Looks like the OP has also changed the webmin port

Yeah. Change them back until you understand what you are doing.

Do you mean I should change it back to 22?

As long as my ssh port is set to 22, I have no connection problems.

I think that’s why I changed it in Usermin or Webmin configuration, I thought that would fix my problem.

You’re trying to put ssh and Webmin (and Usermin?) on the same port. That doesn’t make sense.

I changed them back to default…

Webmin on 10000
Usermin on 20000
ssh on 22

I’d like to change my ssh port, provide me a solution please.