Cannot create user with proper permissions

I have multiple Virtualmin virtual servers running.

When I go to Edit Users > Add a user to this server, I can select “Login permissions” = “Email and FTP” and the user will have access to all folders on the virtual server.

I recently set up a new virtual server and when I follow the same procedure, there is a setting titled “Allow access to web directories”. This setting is not visible on the other virtual servers.

The only two directories in the list under “Allow access to web directories” are “stats” and “/home/SERVERname/awstats”. Since these are unimportant directories, this user cannot upload files to the main directory of the site.

Any idea why this is happening for only this virtual server?

If it is a brand new virtual server that will be the only two directories you can grant access to. On a new virtual server, that’s about the only thing that’s in the public_html directory.

With FTP you should still be able to upload anything to that public_html directory you want.

You’re right. My issue was not related to this.

I’m hazarding a guess here: do you have awstats enabled for the new virtual server / only for those virtual servers where you see that option?

“Allow access to web directories” will not be visible on those virtual servers which do not have awstats / webalizer enabled by default under Virtualmin → System Settings → Features and Plugins

If you want the new virtual server to behave exactly like the virtual servers that you have created in the past, in Virtualmin → Edit Virtual Server, under the Enabled Features tab, uncheck awstats and webalizer. This will cause the “Allow access to web directories” options to disappear and you will be able to set the “Login permissions” = “Email and FTP” as before.


Check for - Services ⇾ Protected Directories: Protected Web Directories

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.