Cannot access virtualmin


I recently installed virtualmin on my VPS running Ubuntu 12.04 amd64. I followed the instructions for automatic installation and was able to successfully install it. However, I am not able to access virtualmin panel at It gives me a invalid server certificate error.

When I try, it says: This web server is running in SSL mode. Try the URL instead. Here is the private IP of my VPS

When I try nothing happens. Google Chrome says it could not load the webpage because took too long to respond, or you may be experiencing issues with your Internet connection.

Well at least my net connection is working fine. Can some please suggest a solution or guide me towards what might be wrong.

Could it be that my VPS does not have SSL?

Please help!!!


It’s normal to receive a SSL certificate warning – that’s just a warning that the certificate is self-signed, and not commercially signed.

You can proceed through that warning and log into your Virtualmin system.

And then later, if you want to avoid that warning, you could always purchase a commercial SSL certificate.


Thanks for the reply Eric. However the problem is that there is no option to proceed to the website. Attaching a screenshot below.

Your help is appreciated.

Ok, I disabled the SSL at /etc/webmin/miniserv.conf and was able to access But still not able to access it securely over https. It says invalid server certificate.

What could be the problem here?

Ah, I see, it looks like you’re seeing a problem with a non-default browser option.

In your screenshot, note how it says “You cannot proceed because your server administrator has requested heightened security for this domain”.

That’s the problem there – that your browser is in a mode which prevents self-signed certificates from working.

Can you go back to the normal browser security settings?

Or do you have an alternative browser you can try?