Cannot access Virtualmin via port 10000 on new install

OS type and version Centos 7
Webmin version Latest
Virtualmin version Latest
Related packages N/A

I have installed the latest virtualmin version on a machine, lets call it

When the installation completed successfully, it gave me a message that I could access virtualmin by opening a supported web browser and going to It also provided an alternative with the public ip address of the server.

I have tried both and the request in the browser times out.

I ran the netstat command and got this output:
netstat -na | grep 10000
tcp 0 0* LISTEN
tcp6 0 0 :::10000 :::* LISTEN
udp 0 0*

And I am able to ping the server.

I am not sure where or how to start debugging this. Any recommendations would be appreciated.

Thanks in advance.

Virtualmin needs port 10000 - 10100 to be open in the firewall of your VPS service provider.
Usermin needs port 20000 to be open in the firewall of your VPS service provider.


I issued the following command and found these ports are already open.

firewall-cmd --add-port=10000-10100/tcp
Warning: ALREADY_ENABLED: ‘10000-10100:tcp’ already in ‘public’

I assume that these were opened by the installer. I still cannot get to the login page.

Yes, Virtualmin’s installer does open the appropriate ports in Virtualmin’s firewall. To ensure that your Virtualmin system is accessible from the rest of the internet, you need to open the same ports on the firewall of your VPS service provider.

I figured it out. For some reason port 10000 was not open in the “public” zone for my primary NIC. When I ticked the box for the primary NIC to be part of the public zone of ports available, everything worked.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.