Cannot access site using https

I recently tried to access my website as https://mydomain.tld. When I tried this, I saw the following errors:

In var/log/httpd/error.log[Wed Aug 31 00:32:35 2016] [info] mod_fcgid: server mydomain.tld:/home/user1/fcgi-bin/php5.fcgi(19443) started
suexec policy violation: see suexec log for more details
[Wed Aug 31 00:32:41 2016] [info] mod_fcgid: process /home/user1/fcgi-bin/php5.fcgi(19443) exit(communication error), terminated by calling exit(), return code: 120

In var/log/httpd/suexec.log[2016-08-31 00:32:35]: uid: (500) gid: (500) cmd: php5.fcgi
[2016-08-31 00:32:35]: target uid/gid (500/500) mismatch with directory (503/502) or program (503/502)

My VPS has one virtual server. There is a user, user1, who ‘owns’ the virtual server and whose UID/GID are 503/502. All of the files in /home/user1 are owned by User1, all directories have 755 permissions, and all files have 644 permissions.

If I understand the error messages properly, suexec is being called by UID 500 and that is the root cause of the problem. When I looked at running processes, I see that httpd is being run by uid 48 and that /usr/bin/php-cgi is being run by UID 503. UID/GID 500 is a legitimate user, but I do not understand why that user is involved in this matter.

Can you suggest what I may have configured improperly?