Can send emails but not receive them

Hi all,

ok so I installed virtualmin, not my first time, and I can send emails but not receive them, I checked all tutorials in virtualmin, but I seem to be missing something, can anyone help ?

I get this error returned when I try to send myself an email:

Host said: <> : 451 - 451 4.3.5 < Recipient address rejected: Server configuration problem

I’ve tried looking through configurations, checking error logs, any ideas ?


Check if port 25 is open - I e. not blocked by your service provider. Provide log entries. The community will be able to provide specific suggestions on the basis of what your logs show.

Yes thank you, port 25 is defiantly open:

Looks like I found the problem…


On investigation, greylisting was enabled but virtualmin was not recognising that it was…

I changed the file /etc/default/postgrey:

It was this: POSTGREY_OPTS="–inet=10023"

changed it to


then I restarted postgrey, and in virtualmin it started to recognise postgrey was working correctly.

Then everything was getting greylisted from my other custom domains, so i disabled greylisting, and everyting worked as expected :slight_smile:


This topic was automatically closed 4 days after the last reply. New replies are no longer allowed.