Can receive emails but cannot send. VPS Provider blocks outbound 25 but allows smtps

Hello my VPS Provider blocks outbound port 25
I can receive email but cannot send and I want to be able to do both.

I did the following tutorial for enabling smtps but had no luck, I’m still getting Connection timed out

SMTPS and Submission Configuration | Virtualmin.

What should I do?

Hello @MariosX and welcome to the community.

This blocking of port 25 for outbound email is quite a common problem. There are lots of VPS hosts which do this. However, here is an easy and free way for you to test your new Virtualmin install and send low volume outbound email:

Thanks for your kind help.
I would rather fix it myself as I’ll be hosting many domains & virtual servers.
Thanks again

FWIW, enabling smtps on port 465 or 587 is only for your mail clients to connect to your mail server. It has nothing to do with how your mail server sends mail to other mail servers. That will still require port 25.

1 Like

So my only option is to change a VPS Provider or change mail provider like a relay host or G Suite, Office 365.

Another thing that occurred to me, I Started using G Suite / GMAIL on a domain, setup all mx, txt, dmarc required records. I can receive and send emails by using my mail clients with my domain fine. However, I cannot send email from WordPress I have to configure an add-on which will use a Gmail API in order to send emails from WordPress.

Is it possible to send emails directly from my Virtual Server without having to configure anything?

I thought this is why we setup txt records

Yes, if your host blocks port 25, you will have to relay mail, or change hosts.

Wordpress mail wont work becasue it tries to use the default local email server via phpmail. if the local email server cant mail out, neither can WP. Im sure there are other options for connecting WP to your gmail account. Ive never used any though. But thats not ideal in a hosting environment where there are many many users.

YES, Virtualmin, webmin or just the mailserver do this by default but need port 25 open.

I don’t understand why but my provider says it blocks outbound 25 but has submission port open.

Taken from their FAQ:
WHY IS PORT X CLOSED? IS IT BLOCKED BY DESIGN?
Unless you have a firewall enabled, all ports for your connection should be open since ~okeanos-knossos does not block them. The sole exception to this rule is port 25 which is blocked to prevent VMs from sending spam mail. You should be able to use port 587/submission though, if your mail server supports it.

Do they mean that I can use port 587 for sending?
I can receive mails but cannot send

As a temporary solution I’m using G Suite, I added MX records, domains and the only downside is I’m using the GMAIL API and I’m configuring everything.

Also I found out that I can change the PHP mailer sender port.

Now I’m looking for a way to configure postfix

well… change hosting provider, simple is that. you paying to be limited meh - you paying for limits, host your self from home or get proper host.

1 Like

I get my VPS for Free.
I get to create up to 8 Virtual Machines with up to 16 CPUs, 16GB RAM, 200 HDD, 8x IPv4, Unlimited IPv6

Everything is Virtual though, I don’t think I get Barabone Dedicated Hosting but perfomance is good and it’s free

That’s wonderful - you have a free VPS with solid specs - not like the free but modest spec 1 GB single core CPU that atlantic.net offers. Good for you.

However, if the VPS host has blocked port 25 then there is nothing which you can do, no configuration option that you can apply, which will enable you to send outbound email from that VPS. The only way around it is to use a smarthost / mail relay service.

I told you so on 30 December, the day you began this topic.

1 Like

You brought back some bad memories of a very brief association with that host. They came highly recommended, but I had nothing but problems with them. I think I had more downtime than uptime. Hopefully my experience was an unusual one.

As for Port 25 being blocked, I know it’s common, but it’s also idiotic. That’s one of the questions I ask before signing up with a host. I don’t want anything blocked. I’m not a spammer, I don’t host spammers, and I’m perfectly capable of managing my own firewall.

The host I’m with now doesn’t block any ports at all. But they do have a verification process for signing up for one’s first server. I think they wanted copies of my driver’s license, a credit card, and my business certificate.

However, because it was an emergency situation in the middle of the night, a senior support tech sized me up over the phone and set up the account immediately, holding the verification in abeyance until the next business day. I suppose they also kept a close watch on the mail volume until then.

My point is that there are better ways to stop spam than to forbid all users from sending mail.

Richard

1 Like