can cloudmin ssh from admin user to kvm host?

I want to harden the ssh server that cloudmin uses before it logs into the kvm host.

example: cloudmin admin user to log into kvm host and not cloudmin root.

I see in cloudmin where I can change each kvm host user and port through change password no problem.

But, I would like for cloudmin to use a system admin with it’s private key before logging into the kvm host with the kvm host admin and key credentials.

Is it possible? If so, where can I change the cloudmin settings to do this?


Not sure of your wording of what server is talking to what. Cloudmin server and kvm host is the same thing to me. But, the cloudmin server can use privatekey auth to manage kvm GUEST machines. Thats setup on the same page where you change the login password you mentioned above.

If your talking about using private key for ssh into the cloudmin server itself, that you’ll have to do manually as it requires copying the key to your local desktop machine.

cloudmin being the main server and kvm host being the virtual containers.

I have set the ssh in main server that cloudmin is installed on to not allow for root ssh. After I did that cloudmin stopped connecting to the kvm containers.
So my question is how do I get cloudmin on the main server to use an admin user from cloudmin/webmin when logging into the kvm containers.

The kvm containers have root disabled for ssh and are already set to log into them with a user admin and key.

I just need cloudmin to stop using root itself and use an admin user from the main server.

The user that you use to log into cloudmin server shouldn’t matter as long as that user has sudo or root privileges… I use non root user with sudo access. NO issues managing machines, or logging into ssh. And root has never been enabled on my servers.

As far as connecting the cloudmin server to KVMs, all that info is set in “change password” for the KVM , then in top right, “change login used by cloudmin”

In the sshd_config I added AllowUsers mysudouser and now it works.

Thank you,

Just for notes: I was able to change the ssh port for the main cloudmin server. But, I had to leave port 22 open on TCP_OUT for cloudmin. I think this is where my problem originated from.