Build website server using Virtualmin at home with ISP blocked port 80

Hi guys, I’m new, as the title that I tried to build a web server using Virtualmin at home but my ISP (Suddenlink) blocked port 80, therefore I got stuck at the step request SSL from Lets-encrypt. I did research and followed to do it before creating a new topic, but most of the post I read has some same kind with me (ISP blocked port 80) is outdated and it so different to follow. So can you guys give me some advice with a pathway should I follow, any link with a new update, or any step-by-step? Thank you!

Operating system and OS version: Ubuntu Server 20.04 LTS
Ports opened: 22, 80, 8080, 8081, 443, 10000, 20-21, 25, 53, 110, 143, 993, 465, 10001-10009, 20000
Domain Registrar: Namecheap

Steps has tried:

  • Enable SSL for virtual server and request SSL from Let’s Encrypt in Virtualmin (http-01 Challenge failed because ISP blocked port 80)
  • Change the HTTP port to another differ from 80 (8080, 8081) and did the same with above. (the challenge still failed)
  • I did run certbot certonly --manual --preferred-challenges dns -d -d -d -d -d
    and --issue -d -d -d -d -d -w /home/vietfoodsquad/public_html (It still fail to challenge, idk, I think some of my step for doing these two is wrong, if your recommend is these two, could you write the step-by-step again for me?)
  • Follow the step from Cloudflare to add nameserver to Namecheap, turn on full in SSL/TLS tab. (This seem to work well but now the new problem is I could not enter back into Virtualmin and my router, the only thing I could access is, so if you recommend this method can you also again write me the step?)

Can you access Virtualmin and your router by their IP addresses rather than their hostnames?


Before doing the Cloudfare => Yes I can access Virtualmin and router by their IP, but after doing Cloudfare => No

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.