BUGs with SSL certificate for webmin


I did used virtualmin before and i could request letsencrypt ssl certificate for a domain, and can also click on the “Copy to Webmin” button to use that certificate for logging in webmin.

However, 2-3 days ago i did a clean install of the newest virtualmin, on ubuntu 14.04. I was able to request lets encrypt ssl for a domain, but cannot “Copy to webmin”. It doesn’t say any error, but the certificate was not used, i still have to make an exception in browsers. I tried firefox, chrome, IE, all of them have problem, even after i clear all caches and cookies.

I tried “Copy to usermin” and see it works . i can open mydomain.com:20000 normally in all browsers with lets encrypt simbol in the address bar.

So i guess there is a bug in the new virtualmin version. I tried installed in another VPS provider and see the same problem.

Could anyone try and confirm?

I too hard this problem today. Same OS, SSL certificate doesn’t copy to Webmin.

The OS i am using is ubuntu 14.04, 32 bit

Thanks Freddy63, any virtualmin staff can help fix the bug? Thank you :slight_smile:

I just updated a cert and pressed the copy buttons for webmin, usermin, dovcot and postfix. All seemed to work except unlike the other buttons the copy to Webmin didn’t disappear even after several clicks. I checked the directory /etc/webmin and still had the old cert files, so I manually copied the new ones from /etc/usermin to /etc/webmin and we’re good.

The tip doesn’t work for me. In my case, i request for a certificate for a new domain sub.domain.com. I tried manually copy the the files sub.domain.com.cert and sub.domain.com.key from /etc/usermin to /etc/webmin, but it doesn’t work.

Maybe you did this already, however I believe you need to restart Webmin.

I can confirm this issue on CentOS 7, also reported on irc channel

there are two issues at the moment:

  1. Let’s encrypt: if the old cert was in other directory before, eg. another directory under the user directory… it tries to read files from that directory BUT into the user directory first tree…obviously that directory there doesn’t exist, so it fails…

eg. SSLCertificateKeyFile /home/myuser/public_html/thisfolder/mydomain.com.key … and it tries to read from /home/myuser/thisfolder/ that doesn’t exist because previously was on public_html/thisfolder

I had a paid cert before and used a custom directory, so in this case the let’s encrypt request doesn’t work

  1. “Copy to Webmin” doesn’t work… when I did that it returned even a message about /etc/usermin

practically it copied into usermin instead of webmin, so I had to manually copy the cert/key from usermin

there must be some oversight in the code…


I had same problem. Virtualmin 1.821 copies the certificate to the wrong folder. Manually copying and restarting webmin fixed it. Looks like a recent bug to me.

In my case, copying & pasting doesn’t work because I’m trying to move from an old domain to a new one to use as default with Virtualmin. I noticed the certificate files for the old domain in the /etc/webmin folder, but it didn’t work even after copying & pasting the files for the new domain, renaming the old files to try to force it to use the new files & restarting the server. I might have to just patiently wait until the bug gets squashed in the next version. I’m currently using Virtualmin 5.05 & Webmin 1.830.

But to those for whom copying & pasting worked, why would you have to do this in the first place? In my second server, I have it so that the files automatically renew every month, and it still says “This SSL certificate is already being used by : Postfix, Usermin, Webmin, Dovecot, ProFTPD” after a couple of renewals. Am I missing something?

I think I found answers to my own questions:

  1. After I edited the miniserv.conf file in the /etc/webmin folder and restarted the server, everything works now. But I believe this very specific bug should be fixed with the next version of Virtualmin.

  2. I started using Let’s Encrypt just less than three months ago, so I might actually encounter this problem sometime this month. Or Virtualmin 5.05 might’ve already solved it. Fingers crossed…

Same problem here trying to copy key in Webmin Configuration / SSL Certificate / Let’s Encrypt

Operating system CentOS Linux 6.8
Webmin version 1.830
Virtualmin version 5.05

Copying cert and key from etc/usermin to etc/webmin and restarting webmin worked.

new install ubuntu 14.04

coping and restart it dont works


this is serious issue, basicaly no ssl

what did u edit in miniserv.conf ?

I had to change keyfile= and certfile= in miniserv.conf to point to my copied key file and cert file. Sorry I did not include this in my previous post.

Try what @zamek said in #15. It should become apparent once you open the file and look through the code.

mine shows correct like


thats what should be ?

we need proper fix

@hostile you should copy the cert and key from /etc/usermin to /etc/webmin.

certfile should equal /etc/webmin/ and the name of your cert file

keyfile should equal /etc/webmin/ and the name of your key file

Then restart webmin. I agree we need a proper fix. Hope this helps.

same problem here… i updated it under the webmin-webmin configuration-ssl settings and here i upload cert and key and it works :slight_smile: