BUG mysql mysql crashed: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (111)

The mysql server crashed overnight.

I’ve tried rebooting, but the following error appears:

ERROR 2002 (HY000): Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (111)

Taambém already tried apt-get autoremove, but it stays infinitely in this message (it does not pass from here):

sudo apt-get autoremove
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages will be REMOVED:
linux-image-3.16.0-60-generic linux-image-3.16.0-62-generic
linux-image-3.19.0-49-generic linux-image-3.19.0-51-generic
0 upgraded, 0 newly installed, 4 to remove and 101 not upgraded.
1 not fully installed or removed.
After this operation, 185 MB disk space will be freed.
Do you want to continue? [Y/n] Y
(Reading database … 213878 files and directories currently installed.)
Removing linux-image-3.16.0-60-generic (3.16.0-60.80~14.04.1) …
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.16.0-60-generic /boot/vmlinuz-3.16.0-60-generic
update-initramfs: Deleting /boot/initrd.img-3.16.0-60-generic
run-parts: executing /etc/kernel/postrm.d/x-grub-legacy-ec2 3.16.0-60-generic /boot/vmlinuz-3.16.0-60-generic
Searching for GRUB installation directory … found: /boot/grub
Searching for default file … found: /boot/grub/default
Testing for an existing GRUB menu.lst file … found: /boot/grub/menu.lst
Searching for splash image … none found, skipping …
Found kernel: /boot/vmlinuz-4.4.0-137-generic
Found kernel: /boot/vmlinuz-4.4.0-128-generic
Updating /boot/grub/menu.lst … done

run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.16.0-60-generic /boot/vmlinuz-3.16.0-60-generic

***!!! It gets infinitely in this message !!! ***

Can anyone help?

I am having the same issue, did you ever fix your issue?