Bug: +FollowSymLinks becomes +SymLinksifOwnerMatch during transfer to another server

SYSTEM INFORMATION
OS type and version Rocky Linux 9.4
Webmin version 2.111
Virtualmin version 7.10.0
Related packages n/a

When transferring virtual servers from a CentOS 7 server to a fresh Rocky Linux 9.4 server using Manage Virtual Server > Transfer Virtual Server, the +FollowSymLinks directive in the Apache configuration became +SymLinksifOwnerMatch (with lowercase ‘i’ on ‘if’) on the new server. I also use the -SymLinksIfOwnerMatch directive and that was preserved during the transfers.

The effect of this was that none of my symlinks worked after the transfers. After doing a find/replace correction in the Apache configuration they started working.

Maybe add the option in the template of the Rocky server, I presume the server will use the template when it creates the virtual server.

+SymLinksifOwnerMatch is more secure and is the recommended way to follow symlinks.

Also this is defined on a virtualmin setup in the root Apache config I think by default.