Browsing to Locally Hosted Virtual Server

I cannot manage to figure out how to browse(using chrome) to a locally hosted server I have created. Everything is set to defaults. The setup is as follows:
Windows Vista OS > Oracle VM Virtualbox > CentOS Linux 6.4 > Virtualmin 4.02.gpl
Within this I have one server: example.com

My system hostname listed on System Information is: 'System hostname vm.example2.com (192.168.0.100)

In my browser I can browse to: https://192.168.0.100:10000/ to access Virtualmin.

When browsing to https://192.168.0.100/example.com it returns :
Not Found
The requested URL /example.com was not found on this server.

When using Virtualmin>exmaple.com>Services>Preview Website it returns:
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, root@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
(the error log says is: 192.168.0.100 - - [20/Sep/2013:16:48:21 +0100] “GET / HTTP/1.0” 500 534 “-” “Webmin”)

I have not got a clue how to be able to browse to the site. This is meant to be my local machine test&dev server. This is the first local Virtual server I have created…

Oh and just in case it isn’t obvious from the above, I am a newbie…thanks!!!

Take a look at the “error.log” in your virtual server’s log directory, it should have logged additional info about the 500 error there.

https:// will only work with your site if it’s set up properly to use secure HTTP, which is a separate feature you need to turn on for the vserver.

ty for your help Locutus.

the error log says:
[Fri Sep 20 15:49:23 2013] [alert] [client 192.168.0.4] /home/example/public_html/.htaccess: Option FollowSymLinks not allowed here
[Fri Sep 20 16:37:19 2013] [alert] [client 192.168.0.100] /home/example/public_html/.htaccess: Option FollowSymLinks not allowed here

I am not sure where 192.168.0.4 has come from as i have been trying with 192.168.0.100 but anyway, all say : Option FollowSymLinks not allowed here

The htaccess is the default drupal one and has the line:

Follow symbolic links in this directory.

Options +FollowSymLinks

So, I need to permit this in this directory. I will have a search to see if you have covered this before (as i have read a lot of your posts!) and report back.

oops, that is in bold due to the hash symbol that was in front of it. sorry

Just to clean up the tread and post the solution to any that stumble upon it.

My issue was that I was unable to browse to my server.
The message in the error log was: “[alert] [client 192.168.0.100] /home/example/public_html/.htaccess: Option FollowSymLinks not allowed here”

This was caused by a line in my .htaccess " Options +FollowSymLinks ".
By changing this line to “Options +SymLinksIfOwnerMatch” I was able to browse correctly.

Hopefully I have understood the discussion and links correctly and simply substituting like this in the file is okay.

A link to the htaccess file: https://code.google.com/p/drupalgooglecode/source/browse/trunk/.htaccess#14

Drupal Patch & discussion: https://drupal.org/node/1269780

Yup, what you did is the correct way to resolve that; glad it’s working now!

-Eric