broke webmin

I was trying to an NTP Server and seemed to do that OK.

tried changing the timezone from EuropeGuernsey to Europe/London and got an error:
Failed to save timezone: Webmin Server did not write new PID to file.

tried stopping and starting from /etc/rc.d/init.d/webmin

but still no access to webmin.
I guess the process has died and I need to get it restarted, any ideas ?


CENTOS 5 and Virtualmin Pro

webmin is not starting. (I can tell when trying to stop it as it then says ‘no such process’)

where would I find an error message about why it i snot starting ?
the system has more than adequate memory.

ok, found error log in /var/webmin/miniserv.error

says that Port 10000 is already in use. so I guess I need to find out how to stop that port so it can be reused.

rebooting would help I guess :o)

Rebooting would solve it. You can also sway a fly by chasing it down with a Buick :slight_smile:

What I might recommend is using "kill" to stop Webmin, and then relaunch it.

To do that, log into the command line over SSH, and type:

ps auxw | grep miniserv | grep webmin

From there, use the kill command to kill that process, give it a few seconds, and then restart Webmin with:

/etc/init.d/webmin start

Let us know how that works!

Oh, I killed my amusing joke with a typo! Doh!

Anyhow, good detective work on your part, you figured out the hard part. Learning to troubleshoot is the tough part of being a sysadmin, you’ll have the syntax for all these tasks picked up in no-time :slight_smile:

thanks Eric,

of course, I remember that commands to check and kill a process :o)
that did the trick !


Now, I’m curious, are you able to set the timezone properly at this point?

had not thought about checking it again :o)

anyway, went back and it was already set to Europe/London.
set it back to Europe/Guernsey - was OK
set it back to Europe/London - was OK

so all seems OK, don’t know why the problem.
thanks for your help.