Brave Web Browser login to Virtualmin hangs w/root "GET /"

debian_version 10.8

Login to virtualmin hangs. Below is the miniserv.log interspersed with the (silent) miniserv.error log:

miniserv.log  166.181.82.44 - root [14/Feb/2021:15:25:28 +0000] "GET / HTTP/1.1" 200 80883
miniserv.log  166.181.82.44 - root [14/Feb/2021:15:25:30 +0000] "GET /unauthenticated/css/bundle.min.css?19629999999999900 HTTP/1.1" 200 146283
miniserv.log  166.181.82.44 - root [14/Feb/2021:15:25:31 +0000] "GET /unauthenticated/css/fonts-roboto.min.css?19629999999999900 HTTP/1.1" 200 406059
miniserv.log  166.181.82.44 - root [14/Feb/2021:15:25:32 +0000] "GET /index.cgi/?xhr-get_user_level=1 HTTP/1.1" 200 1
miniserv.log  166.181.82.44 - root [14/Feb/2021:15:25:32 +0000] "GET /index.cgi/?xhr-get_available_modules=1 HTTP/1.1" 200 1416
miniserv.log  166.181.82.44 - root [14/Feb/2021:15:25:32 +0000] "GET /index.cgi?xhr-manage-config=1&load=1 HTTP/1.1" 200 2

I was able to login by shifting to chrome from brave, and this is the successful miniserv.log:

miniserv.log  166.181.82.44 - - [14/Feb/2021:15:22:30 +0000] "GET / HTTP/1.1" 401 5013
miniserv.log  166.181.82.44 - - [14/Feb/2021:15:22:36 +0000] "GET /unauthenticated/css/bundle.min.css?19629999999999900 HTTP/1.1" 200 146283
miniserv.log  166.181.82.44 - - [14/Feb/2021:15:22:36 +0000] "GET /unauthenticated/css/fonts-roboto.min.css?19629999999999900 HTTP/1.1" 200 406059
miniserv.log  166.181.82.44 - - [14/Feb/2021:15:22:37 +0000] "GET /images/favicons/webmin/favicon-32x32.png HTTP/1.1" 200 1787

Here are some things for you to do so that Brave Web Browser works as expected:

@jabowery hi, i think you should ask this on brave forums as all other Web browsers which support html5 standards have no problems. Even chromium browser :thinking: