Blank page after logging into Virtualmin

Hi i have a problem with virtualmin/wemin server.
After the update (from original source) and login, the virtualmin webpage it’s blank.
This is a server with LAMP CENTOS 6, all site installed works and console it’s ok, but the webpage no.
It’s possible to find a solution without deleting anything or losing data?
Thank’s a lot.


We will try and assist, @adlsrl. All your websites, their content and databases appear to be intact, so don’t worry unduly. It is possible to find a solution without deleting anything or losing data.

Let’s see if we can get Virtualmin to work again. Could you:

sudo service webmin restart
sudo service usermin restart

Let us know if that throws an error.

Just done but blank page.

So: no error on restarting webmin + usermin but you are unable to access virtualmin.tld:10000 - it shows a blank page.

Could you try to access Virtualmin via the IP address instead of the hostname? E.g. instead of virtualmin.tld:10000

I also read here (see that a switch to the Authentic theme could trigger such an issue while upgrading. Could you as a precaution and a remedy to this, also:

mkdir /etc/webmin/authentic-theme

Im logged via IP same blank page…

But it’s possible to write me an step by step the guide to restore the theme?

Launching this command: mkdir /etc/webmin/authentic-theme

I recive cannotcreate directory “/etc/webmin/authentic-theme”: FIle exists

Well, a step-by-step guide is not necessary as updates are supposed to be flawless for the most part. Unfortunately for you it was not and a possible reason for it could be the theme, though we don’t know for sure if that’s the actual reason. Diagnosis by means of forum messages can be such fun.

While we work on eliminating the theme as culprit, here is some documentation for you to look at:

Launching this command: mkdir /etc/webmin/authentic-theme

I recive cannot create directory “/etc/webmin/authentic-theme”: FIle exists

How to fix the theme?

That’s fine, then. The theme has been installed successfully. It is likely not the culprit.

Ok what can I do now?

I am at a loss about what to do next. If I was at the terminal then I would check for a few things. If I knew your domain name or IP address then I would look for errors (right-click | Inspect) in the browser which might give me more clues.

Since I do not have access to either, I am stuck. Maybe someone else can suggest other approaches.

Be assured that your websites and data are not lost, even though my initial attempt at resolving this was unsuccessful.

The ip is
And the ispection is:

For what it’s worth, I am not getting a blank page. I am getting in my Chrome browser (after a 30 second wait)

This site can’t be reached
****  took too long to respond

The connection is timing out. Could you recheck that the firewall has ports 10000 to 10100 open and also post the output of:

netstat -an | grep :10000

It’s not possible to access because i have a firewall, but i dont understand because the ui on webpage dont work… all site are up!

That’s correct, @adlsrl. All sites are up because ports 80 and 443 have been configured to be open in the firewall of Virtualmin as well as any firewall that your VPS host / service provider may offer. However Virtualmin GUI uses port 10000 which may not be open - this seems to be the case based on what I have seen so far. You need to confirm that it is open before we can diagnose this issue further.

Perhaps your VPS host / service provider can assist if you open a trouble ticket with them - just say that you need to let people access port 10000 from the net so could they configure the firewall accordingly.

The GUI port 10000 it’s open probably is an wrong update but i dont have another idea.
It’s possible to find a log?

Log for firewall offered by your VPS host / service provider? I don’t know…

Let’s try something wild that may get you access to Virtualmin even if port 10000 in not open in the VPS host / service provider firewall! This method is perfectly safe and easily reversible if it does not work. In Virtualmin -> (or any other domain) -> Server Configuration -> Edit Proxy Website, in the " Proxy to URL" field, enter and set “Proxying enabled?” to yes. Click “Save and Apply”.

Then open in the browser. If everything works as I expect, you should see the Virtualmin GUI / login screen instead of the normal website associated with the domain.

I shall await your feedback.

hi, what time zone youre in? I can have look with you, if you dont mind voice call / video call over whatsapp - I actually would like to see what is happening when you load your page from your side. No need to control your pc or anything but we can do via teamviewer or just your phone camera and do trouble shooting as we speak… let me know.

edit I am in UK time…

Hi my time zone is Italy if you want call me, send me an email with you number.

I dont have idea how to set all. I dont understard why the server is up but the ui no after one probably update.