Bind9 Zone defaults

Hello, everybody,

i have the following problems, i installed virtualmin on a debain 10 yesterday. Every time I create a new domain I have two entries in the named.conf.local in the zones that allow a zone transfer. These are the IPs and In detail it looks like this :slight_smile:

zone “test.test” {
type master;
file “/var/lib/bind/test.test.hosts”;
allow-transfer {;

I have entered other servers for allow-transfer, but unfortunately these servers are not taken over. Can anyone help me here?


It’s hard to tell exactly what’s happening but servers use port 53/udp to communicate, I would make sure that both inbound and outbound connections are allowed on both servers with port 53/udp.


thank you very much for your answer. I think I expressed myself wrong, it is so that the bind works in principle. I just can’t use virtualmin/webmin to set which servers are allowed for a zone transfer. It seems that virtualmin ignores the user configuration and adds the two servers described above. This seems to be a template that is always used to create the zone files. If I correct the values by hand the bind works without problems. I just can’t find where the servers ( and in the config come from.

Have a look at Webmin/Servers/BIND DNS Server/domainname/Edit Zone Options and there you would be able to edit allow transfers:

I just can’t find where the servers ( and in the config come from.

It’s in Virtualmin/System Settings/Server Templates, template name and BIND DNS domain option on dropdown.

Hello, Ilia,

I want to thank you from the bottom of my heart for your help. After I added an allow-transfer option via Virtualmin/System Settings/Server Templates the mentioned servers ( and disappeared. Thank you very much

I’m just wondering where these entries came from since these are not computers from my network.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.