Bind you pain in the ***

OS type and version Debian 11
Webmin version 2.021
Virtualmin version 7.7Pro
Related packages SUGGESTED

Hi gents,

Ok its been a while since we posted anything here.

Anyway, we decided to upgrade our old Debian 10 server to Debian 11 Just like many times before when we have upgraded all seemed to install well.

Now we happen to use a few Virtualmin GPL servers as our Salve DNS servers. This has worked well until now.

What seems to be occuring is that now as we are migrating each host from the old Virtualmin server to the new one, it moves fine but seems to be having issues creating the Save zones.

It seems to create them but when I try to confirm that all is working well with Bind on one of the slave servers when I look for the zone it rports the following issue.

File not found — /bind8/edit_*.cgi?

If I look in the /etc/bind/named.conf.local the zone appears to be there

then when I look for it in


Thats there as well. Then even when I run a dig against the salve DNS servers they respond correctly.

Any ideas?

Ok this appears to be a problem we encountered in April, Jamie’s suggestion of deleting the

file /etc/webmin/bind8/zone-names works however it needs to be done with every server move.

Something broken here.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.