bind transfer keeps saying connection refused

Hello,

  • I have set up 4 new virtualmin servers. (Scientific Linux 6.3 and named vm1 - vm4
  • The firewall of each server is set to the option “Block all except ports used for virtual hosting”. So also port 53 is stated “accepted”
  • On every server I add (Webmin Server Index) all the other servers. I use ns1 - ns4 because they pointed to the correct corersponding ip-adresses.
  • Also did that on cluster name servers within bind configuration

When I add a new server it creates this also on the slave servers. This is working fine. But the value of this domain is empty.

When I excecute the command within virtualmin “test zone transfer” then it says for al the servers (I use xx by purpose due to privacy):

from 1xx.43.xx.140 : Failed : ;; Connection to 1xx.43.xx.140#53(1xx.43.xx.140) for mydomain.com failed: connection refused.

and so on

I tried a zone transfer also with the firewall on all servers off: same problem.

With the firewall on the command: netstat -an | grep :53 give the folowing output (again xx are used for privacy reasons:

tcp 0 0 127.0.0.1:53 0.0.0.0:* LISTEN

tcp 0 52 1xx.43.xx.149:22 2xx.122.1xx.52:53019 ESTABLISHED

tcp 0 0 ::1:53 :::* LISTEN

udp 0 0 127.0.0.1:53 0.0.0.0:*

udp 0 0 ::1:53 :::*

What did I have done wrong? Please help me on this.

Nobody?

After many hour en feedback of my registrar it looks like that the installation of Bind sets the following parameter:

{
listen-on port 53 { 127.0.0.1; }

Then I changed that to:

{
listen-on port 53 { any; }

And everything worked fine. Thank’s to Maurice and Sjaak.