Bind Newbie Seeks Help


I have always run servers using an external DNS service and uninstalled Bind. Now though I’m trying to get going with Bind. Why? Well (a) I guess if I set it up as a caching-only resolver that should improve performance (with queries forwarded to my existing external DNS service and the answers cached by Bind).

But (b), as a second stage, perhaps I can provide my virtual server customers with the ability to manage DNS for their domain.

So I have started with a clean install of CentOS 6 and VM GPL. All ports are open. But if I try e.g. “dig” that one request triggers about 25 or so lines like this in /var/log/messages!

May 22 13:46:31 testserver named[2164]: error (network unreachable) resolving ‘’: 2001:500:a::79#53

Although the DNS lookup is working, surely something is wrong? Or if it’s just being verbose, how can I quieten it down? is this to do with IPv6? If so, how do I switch to IPv4 only? (Or would it be a mistake to switch to IPv4 only?)


although I am not up-to-date with ipv6, my best ‘guess’ would be that this specific network is not reachable at the moment. Since the lookup is working it means other networks are reachable …
This can happen if this specific network is not yet ipv6 capable.

Since more and more networks will be able to handle ipv4 and ipv6, I would not return to only ipv4. Eventually all (public) networks will be able to handle ipv6, there are no options left

Thanks Ronald. But the 25 or so log messages for that one query covered a number of different networks. Not just one. I don’t think that the networks were ‘unreachable’ at all. I suspect I was trying to reach them in a way they didn’t support? Viz. IPv6.

Of course you’re right though - got to get to grips with IPv6 at some point! For now I’m wondering how I can switch it off in Bind.

yes we are saying the same thing in other words :slight_smile:
unreachable due to no support of ipv6.
This could also be your ISP is lacking ipv6 support. Not all datacenters have set up support yet.
As far as I understood it, there needs to be a tunnel from ipv4 networks to ipv6 networks much like a wormhole.

Anyway, go to webmin - Servers - Bind DNS server - click on module config in the top left corner of the right pane - choose Display options from the dropdown menu and find Support DNS for IPv6 addresses

Im not sure if this does what you are looking for though as i have no hands-on experience with ipv6

I don’t think so Ronald. It’s under “display options”, so I guess it just affects the interface to the DNS records. Anyhoo - I tried it and it made no difference.

I tried editing named.conf and setting: listen-on-v6 port 53 { none; }; . But that didn’t help.

I found a ‘how to’ for Ubuntu:

I’m on CentOS 6 with VM Pro. /etc/default/bind9 did not exist, so I created it as per the instructions. But woe… No effect.

I find it odd that no one else is bothered by this? (Although I personally love ‘clean’ log files, so that any problems stand out!)

Ha! Got it…

On Centos you need to add:
OPTIONS="-4" to /etc/sysconfig/named

Nice clean log file now. Bliss!

great that you’ve found it.
Personally Im not bothered with those messages in the logfile.
I just filter to what I want to see …