BIND DNS Server named.conf and chroot error after upgrading Virtualmin

SYSTEM INFORMATION
OS type and version CentOS 7.9
Webmin version 2.001
Virtualmin version 7.3
Related packages SUGGESTED

Subject

BIND DNS Server named.conf and chroot error after upgrading Virtualmin

Good day from Singapore,

I have recently just upgraded to Webmin 2.001. However, after the Virtualmin and Webmin upgrade, I get the following error messages:

Virtualmin's configuration has not been checked since it was last updated. Click the button below to verify it now.
Button: Re-check and refresh configuration

Checking Configuration
=======================

The status of your system is being checked to ensure that all enabled features are available and properly configured ..
Your system has 7.63 GiB of memory, which is at or above the Virtualmin recommended minimum of 256 MiB
The BIND DNS server version 8 or 9 does not appear to be installed on your system, or has not yet been set up properly in Webmin's BIND DNS Server module. If your system does not use BIND, it should be disabled in Virtualmin's module configuration page

 .. your system is not ready for use by Virtualmin

Then I navigate to Webmin → Servers → BIND DNS Server and it says:

The primary configuration file for BIND /var/named/chroot/etc/named.conf does not exist, or is not valid. Create it?

Options:
-  Setup nameserver for internal non-internet use only
-  Setup as an internet name server, and download root server information
-  Setup as an internet name server, but use Webmin's older root server information

Button: Create Primary Configuration File and Start Nameserver

All along, ever since the initial deployment of my Virtualmin web hosting control panel on 18 Oct 2021, I have never run BIND DNS Server in a chroot environment. After upgrading Virtualmin last night, the configuration was suddenly and unexpectedly changed to running BIND DNS Server in a chroot environment. I have no idea why and what happened.

So I did a Google search and found the following discussion threads:

Solution

After reading through the above discussion threads, I have solved the problem by performing the following steps:

  1. Click Webmin → Servers → BIND DNS Server

  2. Click Module config at the top left hand corner

  3. Chroot directory to run BIND under: choose None

  4. Is named.conf under chroot directory? choose No

Click Save.

And now BIND DNS Server should be back running normally, without chroot environment. It will revert back to using /etc/named.conf and zone files in /var/named.

Problem solved! I hope this guide is useful to you.

Regards,
Mr. Turritopsis Dohrnii Teo En Ming
Singapore

2 Likes