BIND DNS domain : NS Record tfds1.toofastdad.com cannot be resolved to an IP address

Operating system: CentOS Linux
OS version: 7.9.2009

I do not know why I am getting these errors, I was not getting them until after the hosting company stopped providing DNS for my sites, so I now have some of the DNS with Cloudflare. Can someone please advise on what I should do to rectify this?

Thanks

annekejans.com
BIND DNS domain : NS record tfds1.toofastdad.com. cannot be resolved to an IP address
Apache website : An IPv6 DNS record www.annekejans.com with address 2606:4700:130:436c:6f75:6466:6c61:7265 exists, but this virtual server does not have IPv6 enabled
Apache SSL website : The SSL certificate for this virtual server expired on 23/Apr/2021 20:59
greatorb.com
BIND DNS domain : NS record tfds1.toofastdad.com. cannot be resolved to an IP address
Apache website : An IPv6 DNS record www.greatorb.com with address 2606:4700:130:436c:6f75:6466:6c61:7265 exists, but this virtual server does not have IPv6 enabled
lindsayleejones.ca
BIND DNS domain : NS record tfds1.toofastdad.com. cannot be resolved to an IP address
Apache website : An IPv6 DNS record www.lindsayleejones.ca with address 2606:4700:130:436c:6f75:6466:6c61:7265 exists, but this virtual server does not have IPv6 enabled
seanyelland.ca
BIND DNS domain : NS record tfds1.toofastdad.com. cannot be resolved to an IP address
toofastdad.com
Apache website : An IPv6 DNS record www.toofastdad.com with address 2606:4700:130:436c:6f75:6466:6c61:7265 exists, but this virtual server does not have IPv6 enabled
uxtc.ca
BIND DNS domain : NS record tfds1.toofastdad.com. cannot be resolved to an IP address
Apache website : An IPv6 DNS record www.uxtc.ca with address 2606:4700:130:436c:6f75:6466:6c61:7265 exists, but this virtual server does not have IPv6 enabled
wilsonfoundation.ca
BIND DNS domain : NS record tfds1.toofastdad.com. cannot be resolved to an IP address
Apache website : An IPv6 DNS record www.wilsonfoundation.ca with address 2606:4700:130:436c:6f75:6466:6c61:7265 exists, but this virtual server does not have IPv6 enabled

@toofastdad,

Where are you seeing these errors?

If you are using CloudFlare for hosting the DNS records, make sure you don’t have DNS turned on in Virtualmin as these records are not being used.

The errors are coming from Virtualmin Validation. The error is coming for BIND DNS domain : NS record tfds1.toofastdad.com. cannot be resolved to an IP address

This is my System hostname.

@toofastdad,

Since you are using an external DNS provider (CloudFlare) you should turn off DNS for each domain using it. DNS should only be turned on within Virtualmin if you intend to host your own nameservers.

Is it a problem when the NS record cannot be resolved to an IP address?

BIND DNS domain : NS record tfds1.toofastdad.com. cannot be resolved to an IP address

The issue is not with the other DNS it’s with my BIND DNS Domain

I don’t really understand because everything else is working as expected. How do you host your own DNS?

@toofastdad,

CloudFlare is handling DNS for your domain(s). Setting up DNS in Virtualmin is redundant, and doesn’t actually get used since CloudFlare handles those requests from their end.

If you had setup for instance “ns1.yourdomain.com” and “ns2.yourdomain.com” on your server, then you’d also setup the DNS records within Virtualmin.

*** at which point your domain would also have been pointed to the above nameservers instead of CloudFlare ***

Sounds to me like you are using a stock install, but took no measures to address services/features you were not actually using.

Setting up DNS locally while actually using DNS at CloudFlare is just confusing Virtualmin. The minute you disable the feature for the affected domains (which are using CloudFlare) you will eliminate the errors.

So how does Virtualmin know where to send traffic when you use external providers? The answer is Apache sets up “VirtualHost” records which when a domain points to the server (something CloudFlare is handling) it takes that domain name and matches it against a “VirtualHost”, something called “name-based hosting”.

How do I disable the feature?

@toofastdad,

Navigate to the domain using the dropdown at the top of the left panel.

Then click “Edit Virtual Server”.

Expand if not already expanded “Enabled Features”, then uncheck the feature “DNS Domain Enabled”.

You’ll be prompted to confirm your change, and the process of removing DNS from Virtualmin will begin.

Once you have done so, you may depending on what you’ve configured at CloudFlare need to setup some additional records to get a few things working as intended.

If you’d like, we can do a screen sharing session and I can audit, and recommend additional settings on both ends (your server and CloudFlare).

Repeat the above steps for each domain that you wish to disable DNS for (assuming it’s using CloudFlare).

That would be great if you could help me. I see you are in BC; I’m in Halifax, NS. I cannot do it now as I commitment, and it’s after six here, but let me know when you have time to set something up. I’m not an engineer; I’m an Experience Architect and manage a few websites for some people and my own. I started using Virtualmin without any knowledge a couple of years ago — I know enough to be dangerous.

@toofastdad,

Yes, I’m on the opposite side of the world in good ole British Columbia. As I suspect this will be a quick in and out session (perhaps longer depending on what we discover and you want to learn) just drop me an email by filling out the “Request Assistant” form at: https://tpnassist.com

Be sure to specify where you are from and the best time / date in your timezone and I’ll get back to you with a confirmation. Generally speaking most days and times can be worked into my schedule.

*** If you don’t hear back from me within a few hours, drop me a line here so I can see if there was a hiccup somewhere on my end. ***

That’s great. I appreciate it. I work every day, so my days are not my own, but I will get back to you through the link you provided. I’ll see how my time is and reach out.

@toofastdad,

Is anyone’s days their own? I thought working for myself I was suppose to be the boss, turns out I still have to answer to customers… Dang!

I stopped working for myself about 10 years ago after 20+ years of self employment because I never got a day off. Working for a company has been a little easier but I still have some stressful periods, but I do get the weekends off. :slight_smile:

@toofastdad,

My policy…

I take time off whenever I want or need it.

But the most important thing to always remember in the self employed world is, if you take too much time off unnecessarily then you lose clients.

When I do take off a day, weekend, or week it’s generally okay’d by my clients since they know I put in long hours for them.

Not to mention, my general disclaimer when I take time off is, “Don’t bother me, unless it’s an emergency” meaning if the matter CAN wait til I’m back, then please wait until I’m back.

Most clients have no problem respecting that since again they know I’ll go to the moon and back for them on any given day.

May I ask. I want to shut off the bind for 1 domain because I use Cloudflare for all domains. But it is not possible for this domain because I also use an alias domain and it seems it use bind to handle that. Any hints?

@Havouza,

If you are using CloudFlare to serve up public DNS records (you’ve pointed your domain to CloudFlare nameservers) then having a local DNS server as I’ve outlined earlier in this thread does absolutely nothing. Meaning there is no point in running both a local DNS server and using a provider like CloudFlare.

Hi.
But its not possible to not use it because when I try i get an error that it is not possible because an alias domain use it.

@Havouza,

You obviously don’t understand DNS, and how it works. I’m not going to repeat what I’ve already said multiple times because I’m just wasting my time. I do know what I’m talking about, but the fact you are asking questions clearly means you know more about the topic then I do. Good luck.

I want to apologize for my earlier remarks. It was early, and I was frustrated. The only point I want to make clear is that you only use one DNS provider, so if you delegate a domain for instance to CloudFlare, that domain is now being managed by CloudFlare and will not use your DNS server.

1 Like