BIND DNS domain and resolv.conf and virtual domain

I have installed Virtualmin GPL, webmin, usermin and all seems to work just fine for the default server but when i’m trying to create another one and i try to validate it i get this message
Validate Virtual Servers

Beginning validation of selected virtual servers.
Any problems found will be shown in red …
BIND DNS domain : The DNS record resolves to the IP address ([color=#FF0000]master ip wich work for[/color]) instead of the virtual server’s IP ([color=#FF0000]wich i try to use for a virtual interface eth0:1[/color])

<- Return to validation form

And of course it doesn’t work even locally

I know that for many of you its just too simple, but for me, wich i’m learning alone the linux sistems it’s a big problem.

If any one has an ideea please help me!<br><br>Post edited by: jiontro, at: 2009/02/27 14:17

You’ve got your Module Configuration wrong a bit, it seems. Double check the following options:

Network interface for virtual addresses - This must be a real interface–not eth0:1, or similar. If you want virtual addresses to be on eth0, then you need to specify eth0–Virtualmin will deal with the virtual part.

Default virtual server IP address - If you don’t want the default IP to be the address of the address in the prior option, set it here. So, if you wanted virtual servers to be on the eth0:1 interface address, by default, you’d fill in that IP here.

Default IP address for DNS records - If you have a public IP address that is different from the address(es) on the system, the primary public IP needs to go here. This is if you are running on a home network or similar address that is not dedicated. Obviously, you would need to have port or IP forwarding setup on your router for this to work.

it is correct setted see this:

<div class='quote'>Checking Configuration 	

The status of your system is being checked to ensure that all enabled features are available, that the mail server is properly configured, and that quotas are active …

  BIND DNS server is installed, and the system is configured to use it.

  Mail server Postfix is installed and configured.

  Apache is installed.

  Webalizer is installed.

  Apache is configured to host SSL websites.

  MySQL is installed and running.

  PostgreSQL is installed and running.

  ProFTPd is installed.

  Logrotate is installed.

  SpamAssassin and Procmail are installed and configured for use.

  ClamAV is installed and assumed to be running.

  Plugin AWstats reporting is installed OK.

  Plugin Analytics Tracking is installed OK.

  Plugin DAV Login is installed OK.

  Plugin Mailman is installed OK.

  Plugin Protected web directories is installed OK.

  Plugin SQLite Databases is installed OK.

  Plugin Subversion repositories is installed OK.

  Using network interface eth0 for virtual IPs.

  Default IP address for virtual servers is

  Both user and group quotas are enabled for home and email directories.

  All commands needed to create and restore backups are installed.

… your system is ready for use by Virtualmin.

and maybe its the problem with ip forwording, but where to se this to bind or or to apache? can you give me more details?!