Big issue with VM and IPv6 on Almalinux 9

OS type and version Almalinux 9.1
Virtualmin version 7.5

Hi Community,

I’m setting up a new server on Almalinux 9.1, and I’m facing an issue with assigning an IPv6 address to a virtual server after a reboot. When I try to start NGINX, it shows the error message:

nginx: [emerg] bind() to [2605:a140:1234:5678::1]:80 failed (99: Cannot assign requested address)

I’ve looked into the documentation and I think the problem is related to NetworkManager. Virtualmin stores all the configuration in /etc/sysconfig/network-scripts, but after a reboot, NetworkManager doesn’t seem to read the configuration stored there. When I go to Webmin → Networking → Network Configuration → Network Interfaces → Active, I can see my eth0 device with an fe0 IP address assigned (fe80::250:56ff:fe41:4a41). However, when I go back to “Activated at boot”, I can see my IPv6 addresses assigned to the eth0 device. Selecting the eth0 device and clicking on “Apply Selected Interfaces” successfully assigns the IPv6 address to my network configuration, and I can start NGINX without any problems.

I also tried configuring something in the eth0 device, but after clicking on “Save and Apply”, I faced this error:

Failed to activate interface : sh: line 1: ifup: command not found 

I’m not sure what’s wrong here; I installed the additional package of net-tools, which I thought it should include the ifup command as well as in Debian.

Can someone help me out? Maybe @Joe and/or @Ilia have an idea?

Thanks a lot in advance.

That sounds like a bug. Nothing should be trying to use ifup or ifdown, or network-scripts, on an Alma 9 system. That’s a question for @Jamie, I think. Maybe Webmin only supports the compatibility layer (even though it’s not using network-scripts newer RHEL-based distros can read the old config files, though we should probably stop doing that, too, since presumably it’ll go away eventually).

Short term, it’s also possible to just setup all of your IPs and tell Virtualmin about them rather than letting Virtualmin bring them up.

You may be missing a configuration option to enable that compatibility layer, I’m not sure how that works, actually.

Hi Joe,

thanks a lot for your answer. Yes, lets wait what Jaime says, but yes, any modification will be stored in my case in /etc/sysconfig/network-scripts/ifcfg-eth0 instead in /etc/NetworkManager/system-connections/eth0.nmconnection…

The problem here really is that Webmin doesn’t natively support NetworkManager on systems that don’t have the old ifup / ifdown commands. This is in progress though … I will update this ticket with progress.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

FYI, NetworkManager support has been implemented for inclusion in the next release…

1 Like