Bad Request when on HTTP if redirect all requests to SSL site is set to yes

Operating system: CentOS
OS version: 8.3.2011

When visiting http:// on all sites we’re getting:
Bad Request
Your browser sent a request that this server could not understand.
Reason: You’re speaking plain HTTP to an SSL-enabled server port.
Instead use the HTTPS scheme to access this URL, please.

Sites are configured to:
Service Configuration > Website Options >
Redirect all requests to SSL site: Yes

I feel like this was working previously.

provider of your ssl cert?

Let’s Encrypt is the SSL issuer.
No issues on the https side, though. Works perfect if you specify https://domainname.com

Just if you type in http://domainname.com then we hit the Bad Request.

@eight02 well, what you mean bad request? my site is on for http and https as well - no issues found, also running LEtsencrypt here…

Try this: untick the Redirect all requests to SSL site option and reload apache.
See if your site works in http and https
If everything is working fine? Go back and tick the option to yes and reload apache.
If it shows the Bad Request page than you will need to check your apache logs as why this is giving you the Bad Request.

You can also edit directives manually by going to Services > Configure Website > Edit Directives
add: Redirect permanent / https://yourdomain.com/
under: ServerName
Don’t forget to reload apache…