Bad request errors swamping the miniserv error log file

Every few minutes one particular error message is written out to /var/webmin/miniserv.error. The message is:

[31/Jan/2013:00:47:24 +0000] [] Bad Request : This web server is running in SSL mode. Try the URL https://fqdn:10000/ instead.

(The error message actually shows my fqdn in full but it seemed like a good idea not to leave that visible in this post.)

I have tried the suggestion in the error message, which means I can access my Virtualmin setup with either of the following:

https://fqdn:10000 or https://my-IP-address:10000

Whichever I use has no effect on stopping the errors; the log file continues to get swamped with the same message over and over. In less than a week the log file has accumulated 2,023 entries and over 98% of them comprise this message.

The only option I can remember when first installing Virtualmin was a choice to use https or not to access my installation. I chose yes. Is there something else I should have done besides?

Or in short, what can I do to stop the generation of these messages (I think created by


Hi Mark,

As u & I were both getting our forum Q’s ignored I just thought I would check my /var/webmin/miniserv.error for u.

I’m seeing the same thing in mine, but its only 805k in size, so not a problem 4 me. Saying that, most of the clients I have on this host would not be loging into webmin. Your situation may be differnet.



This appears to be a bug, I’d recommend opening a “bug report” in the issue tracker. I’ve confirmed that when SSL mode is enabled, regardless of accessing through IP address, or hostname (as suggested in the error itself, the error continues to be produced).

Best Regards, Peter Knowles TPN Solutions

P: 604-782-9342