Backups to S3 Fail for one Virtual Server work for another one


Creating TAR file of home directory ..
.. done

Uploading archive to Amazon's S3 service ..
.. upload failed! Empty response to HTTP request. Headers were :

… completed in 2 minutes, 25 seconds

Backup failed! See the progress output above for the reason why.

I have another virtual server that i backup to the S3 no problem on this same physical server (albeit to a different s3 bucket and accont), at this point I’ve tried multipe buckets in multiple physical locations in the USA, made new keys too.

The keys are being used I see that last updated but the actual upload of the .tar file always fails with no helpful error message.



We highly recommend installing awscli package to handle S3 backups.

apt-get install awscli

worked thanks, however my other backup didn’t require this – so wierd

May be related - Amazon S3 backup fails when region is not US Standard [#25170] | Virtualmin.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.