Backup Virtual Servers: "Backup failed : Failed to open /dev/pts/x"

When I choose “Backup Virtual Servers”

Include sub-servers, any plan.

Backup all features

Destination and format: SSH server (provide details, bit unsure about file, but gave a name there)

Checked Transfer each virtual server after it is backed up

Backup format: One file per server

Action on error: Halt the backup immediately

Backup level: Full (all files)

I get: Backup failed : Failed to open /dev/pts/5 : No such file or directory

The number seem to increment every time I try it. (started with 0)

Any idea what it is for and how to solve this?

Can you SSH to the target host with the details you used in vmin? Does the path where the file is to be stored exist and does the login user have permission to write there?

The “failed to open /dev/pts/X” sounds like a generic error while trying to establish the SSH session. Maybe Webmin’s debug logging (turn on in Webmin -> Webmin COnfiguration -> Debugging Log File) gives some more info what goes wrong.

I can login to the target host (my local computer) with the details I entered. The path where the file is stored does exist (however it is a windows machine, so it is sth like C:\ of c:\ if I might need to escape the , both do not work however). The user as write permissions.

I will enable the debugging and see what I can figure out.

Uh-oh. SSH from Linux to a Windows box to copy files? That just BEGS to be causing problems. :wink: I’d suggest FTP, or if available, CIFS.

The path I chose nor an error is shown in the webmin.debug file. I can see that it calls backup.cgi though. Maybe I should try an alternative to ssh.

Indeed… Windows is not overly strong in the SSH area. :slight_smile: It’d be better to use, as I said, FTP or CIFS, and maybe set up a VPN if the server and backup box talk to each other via the Internet.

Doesn’t your server hoster offer FTP backup space?

I tried this today to back up to another linux host, but it results in the same error.

Backup failed : Failed to open /dev/pts/4 : No such file or directory

What I did was I went to the backup page.

Chose to backup only selected virtual servers.
Selected two of them.
Checked include subservers.
Backup all features
Backup destination: SSH server
SSH Server: IP address
File on server: /root/backups/newfile (are there any requirements or restrictions to this path / filename?)
User: root
Password: root password
strftime not checked
transfer each file after it is backed up checked
Halt the backup immediately
Backup level: Full (all files)

I wanted to store all backups on the remote host (which I can connect to with this credentials) in the /root/backups directory.

Considering the backup space, Linode offers backups or you can add another VPS (which I did both in this case).

Any suggestions?

What I see in the logs is:

“cmd=scp -r -P 22 /tmp/.webmin/103233_1_backup.cgi root@ uid= gid=”

Which doesn’t look like a proper scp call to me. It looks like it is missing the destination path. On the destination server there might not be something like /tmp/virtualmin, but it looks like it wants to transfer it there.